MozillaZine

My browser won't play sounds on videos or java animations et

User Help for Mozilla Firefox
Guest
Guest
 

Post Posted August 9th, 2006, 4:39 pm

](*,)
when i go on www.youtube.com or anything with sound
the sound doesnt play!
its not my speakers, because i can use windows media player and things.

can anyone help me??

email me with responses please
** e-mail address removed by moderator **

Old BushVenom
 
Posts: 0
Joined: December 31st, 1969, 5:00 pm

Post Posted August 9th, 2006, 5:51 pm

(1) Do you get sound on YouTube videos if you use IE?

(2) YouTube uses Flash Player for it's videos. Do you have the non-IE version of Flash installed?

elvez
 
Posts: 54
Joined: March 30th, 2004, 4:54 am

Post Posted August 13th, 2006, 5:03 am

This problem has been bugging me for some time as well. My brother have it as well.
One day I just had no sound on flash .. youtube.com etc.
I tried using IE but that didn't help either.

Googling the error shows that a lot of people have this problem, and tries reinstalling flash player, sound card drivers but nothing helps.

Stumbled upon this page just now that fixed the problem for me:
Alright the problem is really the mapping of wavemapper in Windows registry as reported by one member of the forum. All you need to do is to open registry editor by going to Start menu, Run, typing regedit and then Enter. After that, in the registry editor, walk yourself through the tree in the left pane, till you reach

My Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Drivers32

And then on the right pane, right click and click on New, select String value, enter "wavemapper" (without quots of course), ENTER, type "msacm32.drv", ENTER.

Close the editor. No need to restart. Video on Google and YouTube et al would work fine now.

Thanks to the member who pointed out the key. I just mentioned the procedure.

Have a nice day!


I followed the instructions and restarted Firefox for good measure... Problem solved!

Still don't know why this problem started in the first place though.

Old BushVenom
 
Posts: 0
Joined: December 31st, 1969, 5:00 pm

Post Posted August 13th, 2006, 2:49 pm

elvez,

Many thanks for sharing that solution, which has been somewhat of a problem in the support forums recently. To verify the registry key and value, I went into regedit and confirmed that there is indeed a registry key named Drivers32 which has a subkey named wavemapper which has a string value of msacm32.drv, so that all seems to be legitimate. Hopefully, this will be the answer to that problem for everyone.

CAVEAT: DO NOT EDIT THE REGISTRY IF YOU DON'T KNOW WHAT YOU'RE DOING. YOU CAN SERIOUSLY DAMAGE YOUR COMPUTER IF YOU GET IT WRONG. ALWAYS BACK UP YOUR REGISTRY BEFORE MAKING ANY CHANGES.

msacm32.drv is a part of Microsoft Sound Mapper (along with the associated .dll file) and is a software/hardware interface that comes with the Windows OS.

scratchbass
 
Posts: 4
Joined: September 10th, 2006, 4:03 pm

Post Posted September 10th, 2006, 4:25 pm

bushvenom wrote:elvez,

Many thanks for sharing that solution, which has been somewhat of a problem in the support forums recently. To verify the registry key and value, I went into regedit and confirmed that there is indeed a registry key named Drivers32 which has a subkey named wavemapper which has a string value of msacm32.drv, so that all seems to be legitimate. Hopefully, this will be the answer to that problem for everyone.

CAVEAT: DO NOT EDIT THE REGISTRY IF YOU DON'T KNOW WHAT YOU'RE DOING. YOU CAN SERIOUSLY DAMAGE YOUR COMPUTER IF YOU GET IT WRONG. ALWAYS BACK UP YOUR REGISTRY BEFORE MAKING ANY CHANGES.

msacm32.drv is a part of Microsoft Sound Mapper (along with the associated .dll file) and is a software/hardware interface that comes with the Windows OS.



you are a legend, i love you!
Scratch

Daifne
Moderator

User avatar
 
Posts: 123048
Joined: July 31st, 2005, 9:17 pm
Location: Where the Waters Meet, Wisconsin

Post Posted September 10th, 2006, 7:02 pm

I removed your e-mail address because we do not give email support. To do so would deprive other users of the information offered in a response to your topic. More importantly, spammers harvest email addresses from public forums like this.

Bluefire310
Guest
 

Post Posted September 18th, 2006, 9:20 am

I'm having this exact same problem, but I'm using a Mac OSX. Anyone know how to fix the problem on that system?

Underwood 5

User avatar
 
Posts: 357
Joined: October 21st, 2004, 9:38 am

Post Posted September 18th, 2006, 10:01 am

Bluefire310 wrote:I'm having this exact same problem, but I'm using a Mac OSX. Anyone know how to fix the problem on that system?
Do you have the Flip4Mac plug-in installed? If not, type flip4mac in the address bar and hit return.
System Requirements


Mac OS X version 10.3.9 or later


QuickTime version 6.5 or later
Running a Mac.

Bluefire310
Guest
 

Post Posted September 18th, 2006, 11:35 am

Okay, I installed the Flip4Mac plug-in, but I'm still not getting any sounds from YouTube (I'm using that to test for internet sound).

Underwood 5

User avatar
 
Posts: 357
Joined: October 21st, 2004, 9:38 am

Post Posted September 18th, 2006, 6:02 pm

Did you restart Firefox after installing the plug-in? I assume you can hear the alert beeps, music with QuickTime and the startup chime.

If it's just YouTube, go into the preferences and see whether the round, green, WMV/Flip4Mac icon shows up. If it isn't there, something's wrong from the get-go. If the icon is there, click on it, then make sure there's a check mark in every box under the Plug-in and Movie tabs. Under Audio, all the check boxes on mine are checked but grayed out. If you made any changes, quit Firefox and restart it.

If that doesn't work, the usual suspects need to be rounded up. Run a permissions fix from Disk Utility, in case the audio thinks it needs root or permission to run from the next-door neighbor's cousin's dog. There's also the sound preferences: Make sure none of the mute boxes are checked under the Sound Effects, Output and Input tabs (don't know your setup, so best to check 'em all, especially if your alert beeps are dead).

If you made any changes to these, it might be worth while to quit Firefox, and restart the machine, as well, so everything loads properly. If it still doesn't work, drag the Flip4Mac file from whatever library it's in (it can be in one of two — your own log-in account's library or the drive's) to the other, quit Firefox and start it again.

Let us know what happened.

EDIT: If the WMV/Flip4Mac icon doesn't show up in the preferences, run a permissions fix. If changes to the permissions were made but the icon still isn't there, restart the machine and check again.
Running a Mac.

Bluefire310
Guest
 

Post Posted September 18th, 2006, 7:48 pm

Okay, I did everything you told me.
Flip4Mac should be working fine - the icon shows up and I checked what I needed to. I ran a permissions fix. I double-checked the sound status in Preferences. I restarted the computer.
My internet is still as silent as the grave. I can see YouTube videos and I can see Flash movies, I just don't hear anything.

I'm perplexed.
Seriously, the sound on the internet worked fine a few days ago, and I haven't been doing anything differently.

Underwood 5

User avatar
 
Posts: 357
Joined: October 21st, 2004, 9:38 am

Post Posted September 18th, 2006, 10:46 pm

Bluefire310 wrote:Seriously, the sound on the internet worked fine a few days ago, and I haven't been doing anything differently.
Do you have sound with Safari? Are you running a router? Airport or other wireless connection?

If you have sound with Safari, here's some more Firefox drill. This taps me out, I'm afraid.

Trash the org.mozilla.firefox.plist file from the preferences folder inside your own library folder, then restart Firefox.

If that doesn't work, do a Firefox safe start. Paste the following line:

/Applications/firefox.app/Contents/MacOS/firefox -safe-mode

into the Terminal and hit return, then click on Continue, at the bottom left, when Firefox starts. Firefox will be running bare-bones. Then type YouTube in the address strip and hit return. If you have sound, it's probably a bad extension causing the trouble.

If so, restart Firefox normally, go under Tools to Extensions, then right-click/control-click each extension and disable them all. Then restart Firefox and try YouTube again. If you have sound, turn half the extensions back on and restart Firefox. Go back to YouTube.

If you still have sound, turn half the remaining extensions on, restart Firefox and go back to YouTube. If you don't have sound, turn off half the extensions you just turned on, restart Firefox and go back to YouTube. Keep that up until you do have sound, then kill the bad extension

If none of that works and you don't have sound even when playing a movie trailer on the Apple site with QuickTime — or even if you do but still no sound at YouTube — download another Firefox and trash the old one. You can reload any extensions, but save your bookmarks.

Drag the bookmarks.html file out of the profle folder and save it somewhere. Trash Firefox in the Application folder, the Firefox folder in the Application Support folder inside your Library folder, anything that says Firefox in the FullCircle folder inside the Applications Support folder, and the org.mozilla.firefox.com plist.

Install the new Firefox and try YouTube again. It you've got sound, quit Firefox, go into the profile folder and trash the bookmarks.html file, then drag your old one in.

Let us know the upshot.
Running a Mac.

Old BushVenom
 
Posts: 0
Joined: December 31st, 1969, 5:00 pm

Post Posted September 19th, 2006, 5:56 pm

If Underwood 5's suggestions don't solve the problem, try this possible solution:

http://forums.macosxhints.com/showthread.php?p=307805
Just fixed it myself, it was incredibly simple:
I dumped the complete Macromedia Folder that lives in ~/Library/Preferences

Underwood 5

User avatar
 
Posts: 357
Joined: October 21st, 2004, 9:38 am

Post Posted September 19th, 2006, 6:28 pm

bushvenom wrote:If Underwood 5's suggestions don't solve the problem, try this possible solution:

http://forums.macosxhints.com/showthread.php?p=307805
Just fixed it myself, it was incredibly simple:
I dumped the complete Macromedia Folder that lives in ~/Library/Preferences
Interesting. I went into Preferences and found the Macromedia folder, but it's empty. Why would it be there, but empty? Maybe some update kills it. I checked the drive's Library folder but it doesn't have a Macromedia folder.
Running a Mac.

johnboy
 
Posts: 50
Joined: June 8th, 2004, 2:19 am

Post Posted September 30th, 2006, 8:56 am

i went to the registry editor to add this wavemapper but it was already there. should i add another? i still can't get sound out of any video i watch!?!

Return to Firefox Support


Who is online

Users browsing this forum: Google [Bot] and 12 guests