MozillaZine

FF Spell Checker

User Help for Mozilla Firefox
AllUsernamesHaveBeenTaken
Guest
 

Post Posted November 5th, 2006, 6:27 pm

OK... so what's up with the FF spell checker, and why won't it work?

MontyPalmer
 
Posts: 6
Joined: November 30th, 2005, 4:24 pm
Location: Chicago

Post Posted November 5th, 2006, 6:37 pm

what does not work mean?
Monty Palmer
President
Paltechs
www.paltechs.com

louie55

User avatar
 
Posts: 83
Joined: April 19th, 2005, 11:43 am
Location: Nebraska

Post Posted November 5th, 2006, 7:00 pm

When you type into a text box and you misspell a word, you should get a red line under it. Right click on it for suggestions of correct spelling.

Have you tried this and it is not working??

Louie

TheBigMick
Guest
 

Post Posted November 7th, 2006, 1:26 am

It will show me the in correct spelled words, but it does not correct them. when I right click on the incorrectly spelt word it doesn't do anything except give me an option to enable or disable spell checking (it is enabled by the way or else the red line would not show up) but it does not give me options for the correct word. I have reinstalled the dictionary and also downloaded and installed another dictionary as well (canadian english) but still nothing. when I click on languages it does not show anything but gives me an option to add more dictionarys. I can down load and reinstall the dictionarys again but they still do not show up or allow me to correct mistakes. It also gives me the option to add the word but when I click it, nothing happens and the red line stays. it's like it can not find the dictionaries.

I am a terrible speller and I need some sort of spell check as you can tell from the above post.

Tulik
Guest
 

Post Posted November 12th, 2006, 11:12 am

I have the same problem. I have installed FF2 on my dualboot computer. For English I get the bad spelling underlined but when right clicking there are no options. I tried to install an additional dictionary but it won't work. When right click I get the language selection but it only enables me to download a dictionary and not select the active dictionary.
some notes on my configuration
Dual boot win XP and Ubuntu.
Both OS's have the same FF2 version installed.
I have a shared partition formated as FAT32 (enabling R/W from linux) my FF profile is on the shared partition and is used by both OS FF installation.
On both installation I tried to install the dictionaries but it seems as only English spell errors are underlined but no otitions are given
what may be done to get the speller working?

Naftaly

flanagan
 
Posts: 3073
Joined: February 13th, 2005, 3:27 am

Post Posted November 13th, 2006, 3:16 am

A number of extensions have recently done a pretty thorough job at botching peoples' right-click context menus. One of the most frequently reported such extension is ODF Reader, but there have also been others. I suggest you first try Firefox safe mode. If it works in safe mode, it is one of your extensions causing the problem. While in safe mode, disable all your extensions. Then return to normal mode and re-enable them one by one until you find the one causing the problem. (If you have lots of extensions, you could re-enable them in groups of three or four to make the process go faster.)

If you still have the problem in safe mode, you likely have some other corruption in your profile. In that case, try these:

clean profile
Migrating_settings_to_a_new_profile

Tulik
Guest
 

Post Posted November 13th, 2006, 10:39 am

flanagan thanks very much. Did what you advised (start FF in safe-mode) and the speller worked then back to regular FF and removed the Gbookmarks and now I am happily clicking and posting while the spell checker corrects my mistakes.

Thanks
Naftay

flanagan
 
Posts: 3073
Joined: February 13th, 2005, 3:27 am

Post Posted November 13th, 2006, 2:20 pm

You're welcome. Thanks for letting us know about Gbookmarks.

VanillaMozilla
 
Posts: 13808
Joined: November 7th, 2005, 11:26 am

Post Posted November 13th, 2006, 4:31 pm

I searched AMO, and this extension was not found. Can you be more explicit?

TheBigMick
Guest
 

Post Posted November 13th, 2006, 10:26 pm

Yup, disabling google bookmarks did the trick. Now I have to decide what i want more, Gbookmarks or the spellchecker

VanillaMozilla
 
Posts: 13808
Joined: November 7th, 2005, 11:26 am

Post Posted November 14th, 2006, 6:39 am

Would that be "GMarks", "Firefox Google Bookmarks", or "Google Bookmarks Button"? As far as I can see, there is no "GBookmarks".

flanagan
 
Posts: 3073
Joined: February 13th, 2005, 3:27 am

Post Posted November 14th, 2006, 2:28 pm

We may have lost the OP, but I think it is the second one (Firefox Google Bookmarks): http://www.rjonna.com/ext/gbookmarks.php

VanillaMozilla
 
Posts: 13808
Joined: November 7th, 2005, 11:26 am

Post Posted November 14th, 2006, 3:15 pm

OK, thanks.

VanillaMozilla
 
Posts: 13808
Joined: November 7th, 2005, 11:26 am

Post Posted November 16th, 2006, 9:04 am

Firefox Google Bookmarks confirmed here: http://forums.mozillazine.org/viewtopic ... 09#2603609 .

Zazzy
Guest
 

Post Posted November 16th, 2006, 9:14 am

I disabled all the extensions and it still wouldn't work for me. Could it be a problem with compatibility to WinME? As much as I may hate ME it's what I have for now.

I've returned to using 1.5.0.7

Return to Firefox Support


Who is online

Users browsing this forum: Google [Bot] and 11 guests