MozillaZine

Why can't I see pictures in my yahoo email anymore?

User Help for Mozilla Firefox
Friskies
Guest
 

Post Posted January 19th, 2007, 4:44 pm

I just downloaded Firefox and now when I open my email that has pictures in the email (not as an attachment) quickly I see say 10 boxes for 10 pictures, but instead of all 10 downloading, I only see the top of the first one.

Friskies
Guest
 

Post Posted January 26th, 2007, 4:49 pm

No one knows?

makaiguy

User avatar
 
Posts: 15749
Joined: November 18th, 2002, 6:44 pm
Location: Somewhere in SE USA

Post Posted January 26th, 2007, 6:24 pm

Doug Wilson, "The Makai Guy"
Win7 Home Prem (64bit): FF 40.0.3, TB 38.2.0 ║ Android 4.2.2/4.4.2: FF 40.0.3, no Android TB available, dammit!
What a fool believes he sees, no wise man has the power to reason away - Doobie Brothers

Friskies
Guest
 

Post Posted January 31st, 2007, 8:20 pm

Thanks. I have version 2.0 and I don't see either of these options:

* For images attached to messages: go to the "View" menu and make sure that "Display Attachments Inline" is checked.

* For remote images: go to "Tools -> Options -> (Advanced if using 1.07 or below) -> Privacy -> General" and uncheck the box for "Block loading of remote images in mail messages."
______________________________-

In the View menu there is no display attachments option.

Tools-Options-Privacy there is no general tab or block loading....option. I also check under Advanced and there is a general tab but again it doesn't have the block loading....option.

Friskies
Guest
 

Post Posted January 31st, 2007, 8:34 pm

Here are screenshots of what I'm seeing.

See I only see the top of the first picture in this email.
<img src="http://i9.tinypic.com/2hpirmd.jpg">

<img src="http://i18.tinypic.com/2zjj08w.jpg">

<img src="http://i5.tinypic.com/4ftphz9.jpg">

stephenjoshd
 
Posts: 6
Joined: June 8th, 2006, 9:16 am

Post Posted January 31st, 2007, 8:50 pm

have you tried in other browsers, are you sure this is a firefox issue and not a yahoo one?

jscher2000

User avatar
 
Posts: 9672
Joined: December 19th, 2004, 12:26 am
Location: Silicon Valley, CA USA

Post Posted January 31st, 2007, 10:09 pm

This seems to be a problem with the way Yahoo places that control bar. It is calculating the height of the message before all the pictures load, so the height is too short. To add a scroll bar, see this post: http://forums.mozillazine.org/viewtopic.php?p=2724912#2724912.

In your example, the height is so small, a scrollbar isn't going to really be a useful approach. It would be better to resize the whole darned thing. I'll see if I can figure out the code for that. Meanwhile, try Ctrl+R and see if Yahoo!'s script calculates better the second time around.

Edit: Reloading doesn't seem to help, but if I go Back and then Forward, the message does resize to show all of the message body.

jscher2000

User avatar
 
Posts: 9672
Joined: December 19th, 2004, 12:26 am
Location: Silicon Valley, CA USA

Post Posted January 31st, 2007, 10:42 pm

Okay, please try this:

This is a bookmarklet, a snippet of JavaScript code that makes a change to the displayed web page. It is only designed to work on a Yahoo! mail message in the "Original" or "Classic" viewer. Using it elsewhere might do nothing or might do strange things.

The code:
Code: Select all
javascript:document.getElementById("message").style.height = document.getElementById("message").scrollHeight+"px"; void 0;

Note: that should all be one line, reconstruct as needed.

To make this readily available:
  1. Select and copy the above bookmarklet code to the clipboard
  2. Right-click the bookmarks toolbar and choose New Bookmark
    If the Bookmarks toolbar is not already displayed, you can display it by right-clicking after Help on the menu bar and choosing it from the little pop-up
  3. On the Name line, enter something like Y!-Fix
  4. On the Location line, paste the above script
  5. Click OK to add the bookmark (or Cancel to fuggedaboudit)
Now when you see a Yahoo! message that has been shortened, click the new button for instant relief. If there are problems, please let me know.
Last edited by jscher2000 on February 2nd, 2007, 12:29 am, edited 1 time in total.

dorine1722

User avatar
 
Posts: 95
Joined: November 22nd, 2006, 11:29 am

Post Posted February 1st, 2007, 8:06 am

I guess I just don't understand what you are trying to get me to do. I've done steps 1-5. Where do I click the button for "instant relief"?

btw, I had the same problem as Friskies today when I tried to copy & paste photos from a website into the body of an email I was composing. I sent it to myself to see what happens and there was only the top part of one photo. I c&p several photos.

If an email has an attachment, I click on the box where the photo should be or click on "view", then "download attachment", "Open with...",OK, then picture appears full screen. 4 clicks.

If no attachment and photo should be in body of email, I get one photo or only part of one.

IE7 works fine....all photos, graphics, images come thru with no problem at all. It's Firefox. IETab works fine now. But not Firefox.

And another thing that may or may not be related, my daughter goes into MySpace under FF under my XP acct and it freezes up the computer. I have to not only restart FF, I have to log off and log back on, or else it's slower than dialup. Took 20 minutes to get 5 clicks to respond, (trying to close out, click on start, log off, this is driving me crazy). She won't use FF because MySpace hates it.

Anyway...thanks for all your help. I wish I understood more. I'm learning more every day.

Guest
Guest
 

Post Posted February 1st, 2007, 10:30 am

I had Firefox for about a year and could see pictures in my yahoo emails with no problem. This only started when unstalled then reinstalled the latest version of Firefox. I now have to open IE to see pictures in my email.

Yes, when in Firefox I can hit reply or forward, wait 5 minutes, then hit the back button and see most of the pictures in my email. However I have no idea if I'm seeing all of the pics. Depending on how long I waited to go back, that's how many pics will load up. This is a pain and doesn't give me certainty that I'm seeing everything.

dorine1722 - I use myspace too and I think it crashes because of all the crap someone has on their page. Tell your daughter not to go to someone's page that has a zillion things on it like videos, surveys, multiple pics (that's what the pic section is for), etc.

jscher2000 - Your instructions look pretty complicated, I'll have to try it later when I get home. But is this something I have to do for every single email I open? There has to be a better way.

Friskies
Guest
 

Post Posted February 1st, 2007, 4:39 pm

The post belonged to me, sorry forgot to add my name.

jscher2000 wrote:Okay, please try this:

To make this readily available:
[list=1][*]Select and copy the above bookmarklet code to the clipboard
[*]Right-click the bookmarks toolbar and choose New Bookmark


I highlighted it, right clicked and saved it. I assume that means it's in the clipboard. Neither right clicking or just plain clicking on bookmarks gives me the option of choosing a new bookmark without it booking marking this website I'm on.

jscher2000

User avatar
 
Posts: 9672
Joined: December 19th, 2004, 12:26 am
Location: Silicon Valley, CA USA

Post Posted February 2nd, 2007, 12:25 am

To dorine1722 and Friskies:

I was assuming that you had the Bookmarks toolbar displayed. If not, you can display it by right-clicking after Help on the menu bar and then choosing Bookmarks Toolbar. Once you create the button Y!-Fix once, then you can click it whenever you get a message that has not completely displayed the images. Does that help?

To try the Forward/Back fix, first wait for the "throbber" to stop circling so you know Firefox finished loading images. Go to another page (preferably a fast loading page). Then immediately press the Back button. Firefox should redraw the message with the correct height using the cached copies of the images.

Hope this helps.

Guest
Guest
 

Post Posted February 2nd, 2007, 1:27 am

If a redraw of the page fixes that, this would probably work:
Code: Select all
javascript:(function() {var b=document.body, p=b.parentNode, n=b.nextSibling; p.removeChild(b); p.insertBefore(b, n); })();


In the past, document.body.insertBefore(document.body, document.body) would work, but that stopped sometime around 1.5.0.4.

The link wrapper extension would be a decent work-around for this issue, believe it or not. It reinserts document.body after adding the <wbr> tags.

https://addons.mozilla.org/firefox/2547/

This would spare the user from manually forcing a redraw. I used to see similar problems on microsoft.com pages. I remember an earlier post about this issue but I can't seem to find it. If I remember correctly, resizing the window would force a redraw as well.

jwarren-at-the-well
Guest
 

Post Posted February 3rd, 2007, 5:01 pm

My wife has run into the same problem. (I don't use Yahoo!Mail, but am our home's resident geek. :-) Most of the time, Firefox 2.0.0.1 displays the contents of Yahoo!Mail HTML-filled email just fine, even when the message source is as large as 60KB-80KB ... invariably indicating it has LOTS of HTML coding and perhaps even imbedded images.

But sometimes, it shows messages -- even not-so-large files (e.g. 13KB-33KB) as nothing but the headers. Nonetheless, as I watch the progress message at the bottom-left, as they're "loading", it shows that Firefox IS receiving at least content from websites referenced in the message's HTML content. AND, when I "select All", various areas of the message area, below the header/Subject line, DO get highlighted.

Furthermore, when I use "View Page Souce", it appears that ALL of the message's HTML coding IS there. I.e., Firefox HAS received the message's full content, and even identified various display areas (presumably for received graphics) -- but has blanked it for some reason or other (perhaps slipping the content behind a blank opaque overlay???; donno -- just a wild guess).

But there's something else of consequence: In examining numerous messages in wife's Yahoo!Mail box, it APPEARS that the "invisible" messages are all from the same sites. Visibility is definitely NOT size-sensitive, nor is it date-sensitive! But it DOES seem to be sender-sensitive!

And, as others have reported, the messages ARE fully readable and properly visible when viewed in a non-Firefox broswer -- e.g. the Mac OSX freebie Safari or limp'n'lame Internet Explorer for Mac OSX from The Evil Empire.

Personally, I suspect that the source web-sites that are feeding the HTML-commanded content of the blanked messages are probably following some Microshaft NONstandard web coding aberration ... or Yahoo!Mail is similarly afflicted with following some Microshaft-centric eccentricity ... and the double whammie of Microshaft arrogance + Yahoo myopia tripped-up Mozilla's Firefox implementers. (To quote a common SillyCon {sic} Valley cliche', when all else fails, blame Microsoft! :-)

--jim

jscher2000

User avatar
 
Posts: 9672
Joined: December 19th, 2004, 12:26 am
Location: Silicon Valley, CA USA

Post Posted February 3rd, 2007, 6:35 pm

The formats of HTML email are pretty unpredictable. I'm sure when I send messages from Outlook they are not coded to pass validation against current web standards, and there's nothing I can do about that...

Meanwhile, if you haven't found the workaround yet, check out this thread: Yahoo Mail and Firefox @ MozillaZine Firefox Support Forum.

Return to Firefox Support


Who is online

Users browsing this forum: No registered users and 10 guests