MozillaZine

manage file types blank?

User Help for Mozilla Firefox
maxmil2224
Guest
 

Post Posted January 26th, 2007, 6:26 pm

Hey guys. I have a little problem with my firefox on my laptop. Its a new dell e1705, running xp media center fully updated, and the newest firefox 2.0.0.1.

My problem is that I can't change how firefox manages file types. The setting is in tools -> options -> content -> manage (under file types).

When I click on manage, its blank. There are no file types showing up. When i try to type a file type in the search, the both the remove and change actions are greyed out and unabled to be clicked, and the box which should hold all the file types on my comp is empty. I have a desktop running firefox and its filled with extensions such as .avi, mpeg, etc etc.

Ive searched thoroughly through the forums and these are fixes i tried that have not worked:
1) deleted and renaming the mimetypes.rdf - didnt work, i deleted it and firefox didnt create a new one. i renamed it and nothing happened
2) going to about:config and playing with the different browser and plugin commands - did not work
3) reinstalling firefox - didnt work that box is still blank
4) deleting the profiles folder - didnt work still blank

I really think that there is a program or something is stopping firefox from being able to get a list of file types on my computer. Are there any known programs that could cause this kind of conflict or any windows settings or other settings i could have enabled accidentally that would cause this? Is there a way to edit the registry and fix this?

This is very very frustrating because everytime i click on a link to download a video or an anime ep (bleach 112 for example), a quicktime window opens up and instead of being able to save to disk, the avi or mpeg file is slowly streamed through quicktime. I temp solved this by just deleting quicktime. Now every file i have the option of saving it, which i didnt have when quicktime was installed. Still though, i am unable to manage file types in firefox. Any1 have any idea whats up or is experiencing this problem?

Thank you for the help!

Alice

User avatar
 
Posts: 2627
Joined: April 23rd, 2003, 11:47 am

Post Posted January 26th, 2007, 6:59 pm

How to reset Quicktime browser settings.... see http://kb.mozillazine.org/Quicktime#Qui ... r_settings

How to reset the Download Actions, ...see http://kb.mozillazine.org/Changing_medi ... _behaviour

These links may also help:
http://kb.mozillazine.org/Issues_with_F ... ving_files
Alice Wyman

dickvl

User avatar
 
Posts: 52776
Joined: July 18th, 2005, 3:25 am

Post Posted January 26th, 2007, 7:58 pm

Do you see plugins on the about:plugins page?
For Quicktime you can select which mime types to handle by the QT plugins.
Just remove the ones that you do not want QT to handle.
Quicktime: Edit > Preferences > Quicktime Preferences > Browser: click MIME Settings

You can try to delete pluginreg.dat: Files outside the Profile folder (KB)

maxmil2224
Guest
 

Post Posted January 26th, 2007, 8:32 pm

Thanks for the quick replies.

1st post
ive been reading more and researching the links you sent. the 6 page post about the wmv i have read prior though and none of those fixes helped me. what i did try tho was use a program someone mentioned - regvac cleaner and i got it to delete all my registry keys that were associated with fire fox, i also uninstalled it. i dont think i did a complete job tho bc when i reinstalled it my favorites were still there and the manage file types box is still blank. this is really mindboggling!


2nd post
i looked for the pluginreg.dat and i dont have that file. also, i checked the about:plugin and i have quite a few: adobe, aol, bittorrent, a few different versions of java, shockwave and a mozilla default plugin. they are all enabled except the mozilla default plugin. any ideas on how to enable it?


ty for the quick replies.

i have a question to ask you guys. what does your mimetypes.rdf say. this is a copy of whats in my file opened with notepad

<xml>

<RDF>

<Description>
<NC>
<Seq>
</Seq>
</NC>
</Description>
</RDF>

dickvl

User avatar
 
Posts: 52776
Joined: July 18th, 2005, 3:25 am

Post Posted January 26th, 2007, 8:51 pm

You need to disable HTML in your post, otherwise the forum parser will delete attributes in some of the tags.

That looks like the default mimeTypes.rdf that is used to create a new profile.
Did you look in the correct location for the Profile Folder?
(not in C:\Program Files\Mozilla Firefox\defaults\profile\)

maxmil2224
Guest
 

Post Posted January 26th, 2007, 9:18 pm

sorry about that. this is a repaste

<?xml version="1.0"?>

<RDF xmlns="http://www.w3.org/1999/02/22-rdf-syntax-ns#"
xmlns:RDF="http://www.w3.org/1999/02/22-rdf-syntax-ns#">

<Description about="urn:mimetypes">
<NC:MIME-types>
<Seq about="urn:mimetypes:root">
</Seq>
</NC:MIME-types>
</Description>
</RDF>


the file path i used to get to this mimetypes.rdf is - C:\Documents and Settings\maxmil2224\Application Data\Mozilla\Firefox\Profiles\dpekuksn.default


im not sure why my profile name is dpekuksn. but thats where i deleted the mimetypes.rdf i also deleted the pluginreg.dat one folder up and also deleted the mimetypes.rdf in c:\programfiles\mozilla\firefox\default\profiles


the manage box is still blank. no file types are in there

dickvl

User avatar
 
Posts: 52776
Joined: July 18th, 2005, 3:25 am

Post Posted January 26th, 2007, 9:32 pm

Firefox uses random names for the actual profile folder as a security precaution.

You shouldn't delete files in the C:\Program Files\Mozilla Firefox\defaults\profile\ folder: the files in that folder are template files to create a new profile.

If you start Fx then, at most after looking at about:plugins, Fx should create a new mimeTypes.rdf.
I don't know why that doesn't happen in your case.

maxmil2224
Guest
 

Post Posted January 26th, 2007, 10:00 pm

i did delete both files and they came back. i was able to click inside of the box and get a dialog box saying to change action etc. but there was no file associated with it. when i closed firefox and restarted it i was unable to do this again and the box remained empty and unclickable.

maxmil2224
Guest
 

Post Posted January 26th, 2007, 10:06 pm

just curious. if was able to copy someone else's rdf file that works, would it fix mine or doesnt work that way?

jscher2000

User avatar
 
Posts: 10701
Joined: December 19th, 2004, 12:26 am
Location: Silicon Valley, CA USA

Post Posted January 26th, 2007, 10:14 pm

I was reading the help earlier, and it sounded as though the dialog populated as you accessed media. You could try downloading something and see whether it gets added and thereafter becomes editable.

dickvl

User avatar
 
Posts: 52776
Joined: July 18th, 2005, 3:25 am

Post Posted January 26th, 2007, 10:14 pm

I don't know, but you can try that.
There are only mimetypes and file extensions in that file, so that shouldn't cause problems.

Alice

User avatar
 
Posts: 2627
Joined: April 23rd, 2003, 11:47 am

Post Posted January 27th, 2007, 8:44 am

maxmil2224,

So what is the problem now, exactly? Do you still not see anything listed in the Options -> Content / Manage ... Download Actions listing? Even if no helper applications or download actions have been defined since you deleted the mimeTypes.rdf from your profile folder, you should at least see entries showing filetypes related to plugins. You should be able to select one of those filetypes, for example, a PDF extension, and change the action from the plugin to the default application. Can you not do that for PDF files?

You mentioned seeing a "bittorrent" entry in in about:plugins. Could you please copy the related entry and paste it here, showing the plugin File name and related mime types? Plugins are reflected in the Download Actions listing; it's possible your problem is either plugin-related or related to the associated program you have installed for torrent files, which, when set as a helper application, causes the blank Download Actions listing and mimeTypes.rdf corruption.

Torrent files have been causing various Firefox issues when associated with helper applications, for example, from a forum search:

Download Actions dialog box lists NO ACTIONS; nothing listed
http://forums.mozillazine.org/viewtopic ... 83#2081383

mimetypes.rdf corruption affects 1.5, not 1.0
http://forums.mozillazine.org/viewtopic.php?t=347732

Open with "do this automatically" doesnt remember
http://forums.mozillazine.org/viewtopic.php?t=356337

I didn't know that there was a plugin for those types of files, but I found it discussed here:
https://bugzilla.mozilla.org/show_bug.cgi?id=203571
Mozilla has no built-in support for BitTorrent
...which is a DUP of:
https://bugzilla.mozilla.org/show_bug.cgi?id=236755
BitTorrent) – Support BitTorrent as a file download mechanism
Alice Wyman

maxmil2224
Guest
 

Post Posted January 27th, 2007, 11:14 am

to alice:

Bittorrent
file name: npbittorrent.dll
bittorrent plugin 1
mime type - is blank
descrpition - npbittorent
suffixes - blank
enabled - yes

i have 7 different java(tm) 2 platform edition 5.0 update 6 plugins
npjava32.dll, npjava14.dll, npjava13.dll, npjava12.dll, npjava11.dll, npjpi150_06.dll, npoji610.dll

i also have an aol media playback plugin, which im hoping to delete, the detailed info is

file name npunagi2.dll
mime type - application/x-unagi-2
description - npunagi2
suffixes - unagi 2
enabled yes

ok alice now after reading your post, i deleted bittorent (the newest version with the green icon i think 5.0.5) and i moved the associated .dll for bittorrent out of my program files\firefox\ plugins folder to my desktop and voila. i opened up my manage files and i can see files that are associated with plugins (shockwave and adobe .pdf files )like you said. i am still unable to see file types such as .avi , .mp3 , .mpeg etc.

to jscher2000
now that i can actually see items in my manage file types (related to shockwave and pdf) im going to try out your suggestion and access some media and see if the dialog box becomes populated.

thanks for the help everyone!

Alice

User avatar
 
Posts: 2627
Joined: April 23rd, 2003, 11:47 am

Post Posted January 27th, 2007, 1:52 pm

maxmil2224 wrote:to alice:
<snip>
i also have an aol media playback plugin, which im hoping to delete, the detailed info is

file name npunagi2.dll
mime type - application/x-unagi-2
description - npunagi2
suffixes - unagi 2
enabled yes

Go ahead and delete or rename the npunagi2.dll plugin file. You can also find and delete the associated .xpt file. This is from my notes:
03-13-2006 Searched for npunagi2.dll and disabled these in all Mozilla folders (both X-ed out)
npunagi2.dll
npunagi2.xpt
This is the AOL Media Playback Plugin which starts the activeX control launcher AOLMediaPlaybackControl.exe when using AOL Radio (according to Task Manager) but which doesn't work correctly, at least when I tried in Firefox 1.0.7 with the Mozilla ActiveX plugin npmozax.dll disabled.


maxmil2224 wrote:ok alice now after reading your post, i deleted bittorent (the newest version with the green icon i think 5.0.5) and i moved the associated .dll for bittorrent out of my program files\firefox\ plugins folder to my desktop and voila. i opened up my manage files and i can see files that are associated with plugins (shockwave and adobe .pdf files )like you said. i am still unable to see file types such as .avi , .mp3 , .mpeg etc.

You may be under the wrong impression that the Manage filetypes option shows all Windows filetypes in the Download Actions listing. If you still had Quicktime installed, you could have gone to MIME settings in the Browser tab and added different filetypes such as Mp3. etc., and then those types would appear in the Download Actions listing as opening with the plugin, which you can then change.

jscher2000 has given you the right advice, to look for media files to download and wait for the Firefox "Opening" box to appear, asking what you want to do with the file. Then, assuming that the downloaded file has the correct MIME type, you can select the option for Firefox to "do this automatically", which is what adds the filetype to the Download Actions list. Here are some links you can use to do that:

At the very bottom of this page under Direct links to media files (mid, .wav, mp3, m3u and .wmv) http://wymette.home.att.net/sound.html

More test pages are here: http://kb.mozillazine.org/Testing_plugins

P.S. Did you try just removing the npbittorrent.dll file from the Firefox plugins folder? Just curious whether or not you needed to remove the BitTorrent program itself or just the plugin (I know next to nothing about torrent files).
Alice Wyman

scram69
Guest
 

Post Posted January 31st, 2007, 10:34 am

I have a similar problem, except I cannot get more than 2 mime types to show up in the "Download Actions" window: PNG and TIFF. I am using OSX 10.4 and Firefox 2.0.0.1. I can delete or rename my ~/Library/Application Suppport/Firefox/Profiles/{gibberish}.default/mimeTypes.rdf file and a new one will be created. But each time, I only get the same two mime types: PNG and TIFF. How do I get more types to show up in the Download Actions window?

Return to Firefox Support


Who is online

Users browsing this forum: No registered users and 7 guests