MozillaZine

Problem with sending mail - msg " Cannot copy to sent f

User Help for Mozilla Thunderbird
bullynj
Guest
 

Post Posted February 8th, 2007, 11:06 am

I keep getting this msg when sending mail today :

the messages cannot be moved or copied to sent folder because writing failed. to gain disk space from the file menu choose empty trash then compact folders and try again - is there anything else i can do? Im running version 1.0.6

Daifne
Moderator

User avatar
 
Posts: 123054
Joined: July 31st, 2005, 9:17 pm
Location: Where the Waters Meet, Wisconsin

Post Posted February 8th, 2007, 4:10 pm

How recently have you compacted your folders? Compacting is something that needs to be done regularly in any email program. We recommend weekly, but many of us do it daily. When done often enough, it can be an extremely fast process. Not doing so can lead to problems like those you are experiencing. See this about how to and why it's so important: http://kb.mozillazine.org/Compacting_folders

If you haven't been doing that before, and 'compacting' them now (and leaving a long enough time for the process to complete) doesn't fully resolve the problem then do the following on each account:

Close Thunderbird. Find and delete all of the files with the .msf file extension in your profile folder/Mail http://kb.mozillazine.org/Profile_Folder#Thunderbird including your Local Folders, especially if you are using the global inbox. You must have "View hidden files and folders" on http://spywarewarrior.com/viewtopic.php?t=272 and you need to set "hide extensions for known file types" off (just below View Hidden) if you are using Windows. These are your mail summary files and do not hold any messages themselves. They will be rebuilt the next time you open each folder in Thunderbird. Compact all your folders when you have completed this.

To avoid this happening again, see the tips in these articles:
http://kb.mozillazine.org/Keep_it_worki ... derbird%29
http://kb.mozillazine.org/Performance_%28Thunderbird%29

seoraghu
Guest
 

Post Posted March 21st, 2007, 11:29 pm

I have problem in Thunderbird, I am using this in Ubuntu. And when I send message from one of my account I get the following error.

"The messages could not be moved or copied to folder 'Sent' because writing to folder failed. To gain disk space, from the File menu, first chooose Empty Trash, and then choose Compact Folders, and then try again."

When I say ok, then I get the following error message:
"Confirm
There was an error copying the message to the Sent folder Retry?
Cancel Ok"

As long I click on ok I get the same message and when I click on cancel then it closes. This is happening only for one account while my other three email account are quite fine. Can any one guide me please?

Thanks and regards
Raghu Guest

Daifne
Moderator

User avatar
 
Posts: 123054
Joined: July 31st, 2005, 9:17 pm
Location: Where the Waters Meet, Wisconsin

Post Posted March 22nd, 2007, 8:09 am

Follow my instructions above.

EnnnEmmm
Guest
 

Post Posted September 13th, 2007, 7:37 am

I greatly appreciate the tip. I was having the same issue with upgraded Mozilla 1.7.13 today that refused to copy messages to local sent folders. The messages were going out but dialog still remaining on screen. Also Sent folder contents could not be viewed. Compacting it solved it all. Thanks

MreSailor
 
Posts: 1
Joined: December 3rd, 2007, 4:06 pm

Post Posted December 3rd, 2007, 4:11 pm

I'm having the same problem installing a fresh copy of TB on a Windows Vista laptop, any ideas? Re-installing, deleting the file and compacting are having no effect. I thought it may be permissions but the system has full access to the sent file and directory.

gofetch
 
Posts: 2
Joined: April 30th, 2008, 7:13 pm

Post Posted April 30th, 2008, 7:39 pm

The dreaded error msge:

"the messages could not be moved or copied to folder because writing to folder failed. To gain disk space, from the File menu, first choose empty trash, and then choose compact folders, and then try again."

I tested everything diligently - with numerous iterations - for most of a day and found a solution at the end.

I am migrating to a new computer and am moving from NS 7.01 (has 10 email accounts and the mail folder was about 700Meg) to the latest Tbird and could not get away from the above error message.

What worked:

Install Tbird.
Create first mail account
Restart Tbird
Open: Tools>Account Settings>Server Settings (for my email account) and under "Local Directory" browse to the correct backup folder for that account ( mail.accountname.com ) - click "ok."
Restart Tbird

I had actually given up and was getting ready to start a new approach & there it was!

I moved the backup folder to a better location and reset it - as above - works fine.

NOTE: I had done all of the cleanup work recommended to the backup email folder. Deleted all of the msf files, made sure "Read Only" was unchecked, and cleaned up anything that was out of order.

Hope this helps... what a pain. I had no trouble doing an identical migration for someone else - so this road block was really confusing to me.

diametrix1
Guest
 

Post Posted June 9th, 2008, 10:34 pm

I have tried the solutions for this
issue (including deleting the .msf
files, compacting the folders etc.
and when I highlight the Sent folder,
I see TB building the summary file
for Sent but it just keeps going.
Nothing happens. I do not see the
copy. Then, after I try to send
another mail, it does it again.

diametrix1
Guest
 

Post Posted June 10th, 2008, 1:09 am

I finally had to take the loss
and erase the .msf, .sbd folder
and the files, themselves.

It successfully built a new Sent
Folder, afterwards. The file was
just gigantic. I will compact in
the future.

Thank you.

Migster
Guest
 

Post Posted July 21st, 2008, 9:02 am

Hi,

I have never compacted before (I had no idea about it) and am getting the same error message when sending emails from one particular email account of mine (all of the others work fine). I have tried compacting (there is no response to this), deleting the .msf files and then compacting again but all with no luck...

Unfortunately I cannot completely follow gofetch's suggestion.

Can anyone suggest anything else?

Ely S
Guest
 

Post Posted November 20th, 2008, 4:35 am

Hi guys,

I am having this same problem.

I tried the solution mentioned above to delete all the .msf files and then compact the folders. but the problem remains.

Has a solution been sorted out for this yet?

Any T-Bird upgrades maybe?

Thanks for any help.

xiliyi
Guest
 

Post Posted December 14th, 2008, 5:58 am

Hey there,

I don't know about this in Windows, but using Ubuntu, I was facing the same problem.
You can either always start Thunderbird with super User rights (e.g. from console, using "sudo thunderbird") or try this solution: Change the folder / file permissions. For some reason, the "Trash" file in "~/.mozilla-thunderbird/profilenumber.default/Mail/Local Folders" was owned by root instead by my default profile. Changing this back to the default user profile did the trick.

Example: go to your "~/.mozilla-thunderbird/yourthunderbirdprofile.default/Mail/Local Folders" folder and type
sudo chown your-profile-name Trash

This could as well have happened to other files than Trash, just look out for the "red cross symbol" on files in Thunar.

The same thing also occured when I installed some Thunderbird addons. The solution was the same for me.

guest1111111
Guest
 

Post Posted December 15th, 2009, 12:54 am

Oddly enough, I found that my folders where my mail was were marked "read only"... I went into their properties and unchecked that for all those folders and this problem disappeared.

LIMPET235
Moderator

User avatar
 
Posts: 38762
Joined: October 19th, 2007, 1:53 am
Location: The South Coast of N.S.W. Oz.

Post Posted December 15th, 2009, 12:58 am

This thread is from last year.
Locking this relic.
Ancient Amateur Astronomer
Win-7-HP/IntelĀ® DualCore-2.0GHz/500G HDD/4 Gig Ram/550Watt PSU/350WattUPS/Firefox-20.0-62.0/T-bird-2.0.0.24/SnagIt-v10.0.1/MWP-7.12.
(Always choose the "Custom" Install.)

Return to Thunderbird Support


Who is online

Users browsing this forum: DanRaisch, Google [Bot] and 10 guests