MozillaZine

Firefox 2.0.0.2 not a browser choice in Set Access

User Help for Mozilla Firefox
blstix
Guest
 

Post Posted February 24th, 2007, 7:59 am

I got upgraded to 2.0.0.2 on XP last night, and had a problem with Outlook reporting "Cannot Locate Link Browser" (a dialog box pops up, but Firefox also started up and went to the link). I also get a dialog box ("The system cannot find the file specified") when I click on a link for an attached .HTM file, but like the other issue, firefox opens.

In looking into this, I discovered that Firefox is no longer a choice in the Set Program Access and Defaults dialog (was going there to try to repair the first problem I ran into).

So, I'm looking for help with my first problems (cannot locate link browser and cannot find file specified), and I'm wondering if these problems are related to the second issue (firefox no longer a browser choice in Set Program Access and Defaults).

Any thoughts would be appreciated.

Thanks

Tony-E

User avatar
 
Posts: 8778
Joined: November 5th, 2004, 11:28 am

Post Posted February 24th, 2007, 8:09 am


blstix
Guest
 

Post Posted February 24th, 2007, 8:16 am

thanks, I've fiddled with that, but that doesn't help with the fundamental problem of Firefox not being visible in Set Program Access and Defaults. After I changed the DDE settings, I still had a problem (unfortunately, can't recall what it was...that will teach me to do this too late at night!).

So, i went after the Set Program Access route, thinking that I'd change it to IE, then back to Firefox as a way to fix everything up.

But, Firefox isn't an option in Set Program Access, so I'm currently stuck with IE as my default browser.

blstix
Guest
 

Post Posted February 24th, 2007, 8:26 am

I downloaded and did a full reinstall of 2.0.0.2. Firefox now appears in Set Program Access and Defaults again, and the links from Outlook seem to work correctly as well.

Looks to me like the update version of 2.0.0.2 did something odd with the browser registration (or whatever the mechanism is) and left things in a broken state. This could probably explain the issues that several other people are having as well....hope that this workaround (full reinstall) helps some of them!

AndreasDK
Guest
 

Post Posted February 26th, 2007, 6:20 am

I had the sort of the same problem as blstix after upgrading to 2.0.0.2.
When opening Firefox, it would sometimes pop-up with the standard "make Firefox default browser" dialog, even though I don't use any other browser and therefore nothing should have tampered with Firefox being the main browser. So I did what blstix also tried to do and went to set Firefox as default browser in "Set Program Access and Defaults" but like him I got presented with IE as the only option.

So after reading this thread, I downloaded 2.0.0.2, did a reinstall without uninstalling and now the problem is gone and Firefox is back in "Set Program Access and Defaults".

So here is one more vote for the upgrade being bugged.

tombodette
Guest
 

Post Posted April 30th, 2007, 6:29 am

Had same problem as blstix, and his fix worked. Thanx!
-T

Return to Firefox Support


Who is online

Users browsing this forum: No registered users and 12 guests