MozillaZine

Sunbird 0.5 - add/edit event on remote calendar, error 412

For discussing the Mozilla Calendar, Sunbird and Lightning projects.
mikeymike

User avatar
 
Posts: 2825
Joined: April 24th, 2003, 6:00 am
Location: UK

Post Posted June 28th, 2007, 1:05 pm

I am using my own web server, running IIS 5 (Win2k), which has worked fine with Sunbird 0.2. All my calendar files are stored in a folder accessible via http and ftp, and the user that I use has full access rights to the folder.

I started with a new Sunbird profile, mainly because my old 0.2 one wasn't recognised at all by 0.5. I then proceeded to subscribe to remote calendars, which all worked fine, but then I went to add a test event, and I always get:

An error has occurred
There has been an error reading data for calendar: Personal. It has been placed in read-only mode, since changes to this calendar will most likely result in data loss. You may change this setting by choosing 'Edit Calendar'.

Details...
Error number: 0x0
Description: Publishing the calendar file failed
Status code: 412: Precondition failed

One strange thing is that the file modify date for the calendar in question on the server gets updated to when I last tried to publish, but the event doesn't get added.

JaapB
 
Posts: 8
Joined: June 29th, 2007, 4:44 am

Post Posted June 29th, 2007, 4:47 am

No more calendars in Sunbird after upgrade to 0.5

[Exception... "Component returned failure code: 0x804a0107 [calIICSService.parseICS]" nsresult: "0x804a0107 (<unknown>)" location: "JS frame :: file:///C:/Program%20Files/Mozilla%20Sunbird/js/calIcsParser.js :: ip_parseString :: line 60" data: no]

is the error message with me. No calendar, reaetting the read only does not help.
JaapB

mikeymike

User avatar
 
Posts: 2825
Joined: April 24th, 2003, 6:00 am
Location: UK

Post Posted June 30th, 2007, 1:20 am

Your problem seems to be very different from mine. You probably stand a greater chance of getting help for yours by posting a separate thread (though one suggestion I would make is to just accept that a piece of software that is at version <1.0 is liable to have issues like yours, so I would suggest starting a new profile and importing your old calendar files into the new profile.

rlktest
 
Posts: 5
Joined: June 1st, 2005, 4:10 pm

Post Posted July 21st, 2007, 9:02 pm

I get a similar but slightly different error message as JaapB when trying to import a 0.2 calendar into 0.5, and, sadly, there is no export option in 0.2. Hope someone can offer a suggestion. I get different messages depending on if 0.5 tries to automatically import it or if I manually try to import it.

Image

Image

bvdbos

User avatar
 
Posts: 708
Joined: January 6th, 2005, 11:23 am
Location: Helmond, Netherlands

Post Posted July 22nd, 2007, 12:34 am

You may copy your ics-file from the 0.2-profile, so you don't need to export the calendar.... But it seems wise to manually edit your ics first to look for non-utf8 characters (like é etc)

Return to Calendar


Who is online

Users browsing this forum: No registered users and 2 guests