MozillaZine

Thunderbird Temporary File error

User Help for Mozilla Thunderbird
sappiajk
Guest
 

Post Posted December 10th, 2007, 7:38 pm

Hello,

i am having a hard time sending emails with attachments. If I send an email with a small attachment there is no problem, but if it is slightly bigger, then it wont work. Here are some of my system specs

Thunderbird 2.0.0.9 (plaxo and lightning installed)
Windows Vista
IMAP account

Things I have done:
As noted, I am using an imap account, but I have the drafts sent to the local folder
I removed all the files in the sent folder and put them in a backup folder
I deleted all temporary files in every temporary directory I could find on the computer

I continue to get the error:
"Sending of Message Failed
Unable to open the temporary file C:\Users\Owner\_______________________. Check your 'Temporary Directory' setting."

Please help

DanRaisch
Moderator

User avatar
 
Posts: 107791
Joined: September 23rd, 2004, 8:57 pm
Location: Somewhere on the East Coast

Post Posted December 10th, 2007, 7:41 pm

How recently have you compacted your folders, particularly that Sent folder? Compacting is something that needs to be done regularly in any email program. We recommend weekly, but many of us do it daily. When done often enough, it can be an extremely fast process. Not doing so can lead to problems like those you are experiencing. See this about how to and why it's so important: http://kb.mozillazine.org/Compacting_folders

If you haven't been doing that before, and 'compacting' them now (and leaving a long enough time for the process to complete) doesn't fully resolve the problem then do the following on each account:

Close Thunderbird. Find and delete all of the files with the .msf file extension in your profile folder/Mail http://kb.mozillazine.org/Profile_Folder#Thunderbird including your Local Folders, especially if you are using the global inbox. You must have "View hidden files and folders" on http://spywarewarrior.com/viewtopic.php?t=272 and you need to set "hide extensions for known file types" off (just below View Hidden) if you are using Windows. These are your mail summary files and do not hold any messages themselves. They will be rebuilt the next time you open each folder in Thunderbird. Compact all your folders when you have completed this.

To avoid this happening again, see the tips in these articles:
http://kb.mozillazine.org/Keep_it_worki ... derbird%29
http://kb.mozillazine.org/Performance_%28Thunderbird%29

sappiajk
Guest
 

Post Posted December 10th, 2007, 7:42 pm

Well, I figured out what the problem is seconds after I posted it. The file I was trying to send used Thai Script in the file name. It wouldn't allow the Thai script. Once I changed to English script it went out.

Anyone know how to adjust this so I can send out attachments with thai script?

DanRaisch
Moderator

User avatar
 
Posts: 107791
Joined: September 23rd, 2004, 8:57 pm
Location: Somewhere on the East Coast

Post Posted December 10th, 2007, 7:49 pm

What type of attachment is it? See if this helps -- http://kb.mozillazine.org/Send_attachme ... ttachments

sappiajk
Guest
 

Post Posted December 10th, 2007, 9:00 pm

The attachment is an audio file.
mp3

The text is written in thai so it looks like this.

02 - ลำเตยคำสัญญาที่เป็นจริง.mp3

If I change the text to English font it works fine.

I made the edit as you suggested to sending real attachments and I still get the same error.

Note: The file does send out fine in Outlook.

Thanks for helping

Darzinho
 
Posts: 4
Joined: December 13th, 2006, 7:30 am
Location: Dublin

Post Posted December 11th, 2007, 11:47 am

I had a similar problem. I got the same message when a .pdf attachment I was trying to send had percentage signs and other symbols in the file name.

Renaming the files and reattaching them to the message solved the problem.

Thanks for asking and answering the question yourself!

pavelke
Guest
 

Post Posted August 19th, 2008, 1:13 pm

I have the same problem using windows vista but none of these solutions helps.
This even for amail wit header test and only the characters "abc" typed in the message.
After trying various proposed solutions from other forums too, i now have a similar problem with Adobe distiller.

DanRaisch
Moderator

User avatar
 
Posts: 107791
Joined: September 23rd, 2004, 8:57 pm
Location: Somewhere on the East Coast

Post Posted August 19th, 2008, 1:42 pm

pavelke, you're posting to a thread that is over eight months old. If you hope to get support on your question you should create a new topic and include the following information -- * Which version of Thunderbird? Check Help>About for the version number.
* What operating system?
* What is the exact wording of the error message you are receiving?
* Do you have any extensions installed?
* What kind of mail - POP, IMAP?
* Is your mail service from an ISP, corporate e-mail system or Web-based?
* Are you using an antivirus and/or a firewall program? Which ones?
* Do you regularly compact your folders? Weekly or more often is strongly recommended. Check http://kb.mozillazine.org/Compacting_folders for more information on compacting folders.
* Without divulging your e-mail address or account name, what are your server settings, including server name and port number for:
+ Tools>Account Settings>*account*>Server Settings?
+ Tools>Account Settings>Outgoing Server (SMTP) (at the bottom of the list of accounts on the left)>*server*>Edit?
* Any recent changes in your computer or software configuration that might be relevant?
(including OS or Thunderbird updates, adding extensions or themes, etc. and any security program updates)

dbmonkey
Guest
 

Post Posted October 4th, 2008, 11:56 am

I've just had a similar issue. The PDF I was sending had a few % signs in the file name. This seemed to be the problem. I'm using Thunderbird on a XP pro.

Removed the % signs from the filename - problem solved. The thai script post gave me the clue and I sorted it, so thanks! Then just noticed others have problems with the % sign. Darzinho seems to have had the exact problem I had. I didn't read that far down the page before I'd fixed the problem!

aschur
Guest
 

Post Posted November 14th, 2008, 2:10 am

Hi,
I am a utilizing Vista Basic. Thunderbird 2.0.0.17 and facing the same problem when trying to atach files like ppt xls and doc.
I do not have any problem when using XP.
I tried compacting as suggested. Problem was not solved.
Any advice?

DanRaisch
Moderator

User avatar
 
Posts: 107791
Joined: September 23rd, 2004, 8:57 pm
Location: Somewhere on the East Coast

Post Posted November 14th, 2008, 5:45 am

Note that there were various descriptions of a problem with attachments in this thread, one of which involved Thai script in the file names. If you are not using Thai script, please start a new topic or post a more complete description of the problem you are having so that we can understand what you are seeing.

jinhong
Guest
 

Post Posted May 9th, 2009, 7:31 pm

I am trying to send a doc.file written in Korean. However, every time I try to send it, it says "check your temporary directory." What does that mean? It just suddenly started to do this.

DanRaisch
Moderator

User avatar
 
Posts: 107791
Joined: September 23rd, 2004, 8:57 pm
Location: Somewhere on the East Coast

Post Posted May 9th, 2009, 7:36 pm

jinhong, please start a new topic as you are not using the same script as the original poster.

Return to Thunderbird Support


Who is online

Users browsing this forum: Google [Bot] and 9 guests