MozillaZine

Remove "Open All in Tabs" from Bookmarks

Discussion of features in Mozilla Firefox
realgeorge

User avatar
 
Posts: 459
Joined: May 17th, 2003, 7:56 pm

Post Posted February 6th, 2008, 10:50 am

How can I remove "Open All in Tabs" from the bottom of Bookmarks>Files>lists?

alterna

User avatar
 
Posts: 3993
Joined: January 16th, 2007, 8:27 am
Location: Big Apple

Post Posted February 6th, 2008, 11:32 am

Place the following in your userChrome.css


.openintabs-menuseparator,
.openintabs-menuitem {
display: none !important;
}

http://kb.mozillazine.org/UserChrome.css
http://kb.mozillazine.org/Profile_folder

Note: If creating userChrome.css file, be sure to included the following at the top:

@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* set default namespace to XUL */

realgeorge

User avatar
 
Posts: 459
Joined: May 17th, 2003, 7:56 pm

Post Posted February 6th, 2008, 12:31 pm

Worked great alterna. Thanks for your help

alterna

User avatar
 
Posts: 3993
Joined: January 16th, 2007, 8:27 am
Location: Big Apple

Post Posted February 6th, 2008, 12:37 pm

You're welcome.
"So it goes" - Kurt Vonnegut, Jr.

too_cruel_for_school

User avatar
 
Posts: 16
Joined: April 11th, 2007, 11:15 am
Location: East Moline, Illinois

Post Posted March 6th, 2008, 9:38 am

I'm using FF 2.0.0.12 and Open All In Tabs is still there.
Don't give me a hard time. My stomach hurts me when I laugh too much.

bobb40
 
Posts: 3
Joined: March 18th, 2008, 12:38 am

Post Posted March 18th, 2008, 12:58 am

[quote="alterna"]Place the following in your userChrome.css


.openintabs-menuseparator,
.openintabs-menuitem {
display: none !important;
}

That works well on firefox 2 - thanks!

But it doesn't work on firefox 3beta4 -
can anyone suggest a fix on ff3?

Bozz
 
Posts: 2607
Joined: October 18th, 2007, 1:53 pm

Post Posted March 18th, 2008, 2:02 am

Code: Select all
menuitem[label="Open All in Tabs"]
Thunderbird/Daily/40.0a1

bobb40
 
Posts: 3
Joined: March 18th, 2008, 12:38 am

Post Posted March 18th, 2008, 4:38 am

[quote="Bozz"][code]menuitem[label="Open All in Tabs"][/code][/quote]

How does one use that? Does it go in userChrome.css, or about:config, or ???

alterna

User avatar
 
Posts: 3993
Joined: January 16th, 2007, 8:27 am
Location: Big Apple

Post Posted March 18th, 2008, 5:05 am

userChrome.css


menuitem[label="Open All in Tabs"]
{
display: none !important;
}
"So it goes" - Kurt Vonnegut, Jr.

bobb40
 
Posts: 3
Joined: March 18th, 2008, 12:38 am

Post Posted March 18th, 2008, 5:31 am

[quote="alterna"]userChrome.css


menuitem[label="Open All in Tabs"]
{
display: none !important;
}[/quote]

Thanks, Bozz & alterna - that works fine on firefox 3b4.

too_cruel_for_school

User avatar
 
Posts: 16
Joined: April 11th, 2007, 11:15 am
Location: East Moline, Illinois

Post Posted March 18th, 2008, 11:06 am

Thanks to all for trying to help. I tried everyone of your suggestions and "Open All In Tabs" is still there in FF 2.0.0.12

I guess it's just one of those things you have to live with like taxes. :D
Don't give me a hard time. My stomach hurts me when I laugh too much.

alterna

User avatar
 
Posts: 3993
Joined: January 16th, 2007, 8:27 am
Location: Big Apple

Post Posted March 18th, 2008, 3:13 pm

too_cruel_for_school wrote:Thanks to all for trying to help. I tried everyone of your suggestions and "Open All In Tabs" is still there in FF 2.0.0.12

I guess it's just one of those things you have to live with like taxes. :D


Are you using a custom theme? Occasionally they will override userChrome.css modifications. Try in Firefox Default.

too_cruel_for_school

User avatar
 
Posts: 16
Joined: April 11th, 2007, 11:15 am
Location: East Moline, Illinois

Post Posted March 18th, 2008, 4:34 pm

Yes I forgot about it. It's the Aluminum Alloy theme. I chose it because it includes a toggle switch on the sidebar to open and close it.

That's probably the cause of it. I hate FF standard skin more than "Open All In Tabs". So I guess I'll have to live with it. :)

https://addons.mozilla.org/en-US/firefox/addon/3637
Don't give me a hard time. My stomach hurts me when I laugh too much.

Bozz
 
Posts: 2607
Joined: October 18th, 2007, 1:53 pm

Post Posted March 18th, 2008, 4:58 pm

Add -moz-appearance: none !important;.

Code: Select all
menuitem[label="Open All in Tabs"] {
-moz-appearance: none !important;
display: none !important;
}

.
Thunderbird/Daily/40.0a1

too_cruel_for_school

User avatar
 
Posts: 16
Joined: April 11th, 2007, 11:15 am
Location: East Moline, Illinois

Post Posted March 18th, 2008, 5:33 pm

i tried it and failed again. in my 60 years i've never seen anything so stubborn. :D

just so you'll know i renamed userChrome - Eample.css to userChrome.css so everything that is supposed t be in there is. it's not a css file i made myself. itried the trick at userstyles.org and that didn't work either.

Code: Select all
/*
 * Edit this file and copy it as userChrome.css into your
 * profile-directory/chrome/
 */

/*
 * This file can be used to customize the look of Mozilla's user interface
 * You should consider using !important on rules which you want to
 * override default settings.
 */

/*
 * Do not remove the @namespace line -- it's required for correct functioning
 */
@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* set default namespace to XUL */


/*
 * Some possible accessibility enhancements:
 */
/*
 * Make all the default font sizes 20 pt:
 *
 * * {
 *   font-size: 20pt !important
 * }
 */
/*
 * Make menu items in particular 15 pt instead of the default size:
 *
 * menupopup > * {
 *   font-size: 15pt !important
 * }
 */
/*
 * Give the Location (URL) Bar a fixed-width font
 *
 * #urlbar {
 *    font-family: monospace !important;
 * }
 */

/*
 * Eliminate the throbber and its annoying movement:
 *
 * #throbber-box {
 *   display: none !important;
 * }
 */

/*
 * For more examples see http://www.mozilla.org/unix/customizing.html
 */
 
menuitem[label="Open All in Tabs"] {
-moz-appearance: none !important;
display: none !important;
}
Don't give me a hard time. My stomach hurts me when I laugh too much.

Return to Firefox Features


Who is online

Users browsing this forum: No registered users and 0 guests