MozillaZine

URL hyperlinks do not work

User Help for Mozilla Thunderbird
hyperpain
Guest
 

Post Posted February 26th, 2008, 9:00 pm

Clicking on a URL in an email yields nothing. The cursor changes but does not bring up a web page. I can click on an html file on my desktop and firefox comes up just fine so I believe KDE is configured correctly.

Thunderbird 2.0.0.12

DanRaisch
Moderator

User avatar
 
Posts: 121896
Joined: September 23rd, 2004, 8:57 pm
Location: Somewhere on the right coast

Post Posted February 26th, 2008, 9:20 pm

All that happens when you click on a URL in an email is that Thunderbird sends a call to the operating system to launch the default browser. See this link -- http://kb.mozillazine.org/Setting_Your_Default_Browser

hyperpain
Guest
 

Post Posted February 28th, 2008, 9:27 pm

I'm out of ideas. KDE has Firefox as the default browser. It can pull up URL's in other applications, just not Thunderbird. Is there anywhere in TB that I can force it to use Firefox to open hyperlinks?

DanRaisch
Moderator

User avatar
 
Posts: 121896
Joined: September 23rd, 2004, 8:57 pm
Location: Somewhere on the right coast

Post Posted February 28th, 2008, 9:39 pm

Did you read my post above? Thunderbird sends a call to the operating system. After that it is up to the OS.

Your User Agent string is indicating Windows XP. Is that not what you are running Firefox under?

Daifne
Moderator

User avatar
 
Posts: 123054
Joined: July 31st, 2005, 9:17 pm
Location: Where the Waters Meet, Wisconsin

Post Posted February 28th, 2008, 9:53 pm

(Thanks to Paolo)
Put these lines in user.js file, in your Thunderbird profile:

Code: Select all
user_pref("network.protocol-handler.app.http", "/usr/bin/firefox");
user_pref("network.protocol-handler.app.https", "/usr/bin/firefox");
user_pref("network.protocol-handler.app.ftp", "/usr/bin/firefox");


Of course change the path of the firefox executable, if yours is not /usr/bin/firefox.
Ciao, Paolo

http://kb.mozillazine.org/User.js

hyperpain
Guest
 

Post Posted February 29th, 2008, 3:18 pm

That did the trick

I was trying that earlier to no avail...I just realized I was adding it to the prefs.js file.

Thanks!

Daifne
Moderator

User avatar
 
Posts: 123054
Joined: July 31st, 2005, 9:17 pm
Location: Where the Waters Meet, Wisconsin

Post Posted February 29th, 2008, 5:52 pm

You're very welcome.

DougBain
 
Posts: 11
Joined: August 30th, 2008, 4:43 am

Post Posted August 31st, 2008, 4:24 am

Firefox was my default browser for Thunderbird until some very recent updates (Firefox, Mandrive 2008.1 - so I don't know who's responsible). After that, Thunderbird failed to pick up any browser at all.

Following this and a related thread, in Thunderbird I went Edit=> Preferences=> Config Editor and modified the values of:
network.protocol-handler.app.http,
network.protocol-handler.app.https
network.protocol-handler.app.ftp
from /usr/bin/xdg-open to /usr/bin/firefox

It all seemed OK. Closed; logout; login again; go to Thunderbird and about: config - http has retained the new value /usr/bin/firefox; but https and ftp have been reset to the old /usr/bin/xdg-open. (Thunderbird does pick up firefox as the default browser for normal http sites). I've also tried editing prefs.js with the same result.

How does one get the https and ftp modifications to persist?

Ed1
 
Posts: 942
Joined: January 30th, 2005, 2:33 pm

Post Posted August 31st, 2008, 9:41 am

In Windows Vista32, I had some partial luck by editing the very next listed item in about:config:

network.protocol-handler.expose-all

to change the value from False to True.

On some internet links in email, the FF opens and provides the correct display. On other email internet links, a text or simple HTML version of the web page displays in the browser, without any images, and with the location bar referring to a file on my computer (cache?) rather than a true URL address.

Ed1
 
Posts: 942
Joined: January 30th, 2005, 2:33 pm

Post Posted August 31st, 2008, 10:14 am

What is the correct syntax for those protocol-handler values in Windows Vista?

I know it is supposed to be the path to the firefox.exe. But I don't know if it is merely C:\Program Files\Mozilla Firefox\firefox.exe, or the more complicated way of writing the path (which involves some % signs). . .

DougBain
 
Posts: 11
Joined: August 30th, 2008, 4:43 am

Post Posted September 2nd, 2008, 3:03 am

In Windows Vista32, I had some partial luck by editing the very next listed item in about:config:

network.protocol-handler.expose-all

to change the value from False to True.


In Mandriva 2008.1 toggling network.protocol-handler.expose-all, changes "default", "false" to "user-set", "true"; but on closing thunderbird and re-opening, https and ftp have gone back to /usr/bin/xdg-open, just the same as before

Return to Thunderbird Support


Who is online

Users browsing this forum: Bing [Bot] and 4 guests