How to disable an email account in Thunderbird

User Help for Mozilla Thunderbird
Posts: 2
Joined: March 8th, 2008, 3:11 pm

Post Posted March 8th, 2008, 3:16 pm

I am migrating my domains emails to Gmail so I will be using IMAP. I use to use POP mail and would have the emails download to its own folder (didn't use Global Inbox). On several of my workstations, I have inbox's for several email accounts. How can I keep the email account and all the emails that I had previously do without having Thunderbird check the accounts for new emails. I want to be able to access my old downloaded emails until they are too old and are irrelevant. I can't set the POP3 server and username of the accounts I do not want to check to blank. Is there anyway for Thunderbird not to include those accounts when checking for new emails? I have disabled all the options to "Check for New Messages.." in the server settings but when I click "Get Mail", it still tries to check the no longer existent POP accounts and an error message pops up.


User avatar
Posts: 123063
Joined: July 31st, 2005, 9:17 pm
Location: Where the Waters Meet, Wisconsin

Post Posted March 8th, 2008, 4:12 pm

How about moving all the messages to folders in Local Folders and then removing those accounts?

Posts: 2
Joined: March 8th, 2008, 3:11 pm

Post Posted March 8th, 2008, 4:21 pm

Hmm, that is an option, but it is a lot of emails (14+ gigs) on several computers. Is there anyway to disable both receiving and sending emails with those accounts?


User avatar
Posts: 410
Joined: March 8th, 2008, 4:10 pm

Post Posted March 8th, 2008, 4:31 pm

Hi, That's deja vu, I was just about to ask the same question. I only have 3 accounts I'd like to skip over with "get all new messages" and check manually. I will watch this thread with interest.
Cary G.


User avatar
Posts: 122535
Joined: September 23rd, 2004, 8:57 pm
Location: Somewhere on the right coast

Post Posted March 8th, 2008, 4:36 pm

In Tools->Account Settings->Server Settings->unselect "Check for new messages on startup", "Check for new messages every NN minutes", and "Automatically download new messages".

To prevent accidental manual downloading, change the entered value for the server name, perhaps by replacing periods in the name with commas. Do the same for the SMTP (Outgoing) server.


User avatar
Posts: 185
Joined: November 29th, 2004, 8:48 am
Location: Kenosee Lake, Saskatchewan, Canada

Post Posted September 11th, 2008, 10:36 pm

This has been making me crazy(ier). I use Tb Portable with about four email accounts, one being my work email, and everything is fine at work, but they don't allow me to log on from home. Therefore, I have the first two settings unchecked, and the third doesn't show (presumably because it is IMAP?) and when I am at home, error messages keep popping up that Tb can't log on to my work account. I'm trying to use my GMail account at the time. I just want to be able to disable without deleting the account. Thanks in advance for any help
bomb fight capitalist scramble missle worm destroy
--The NSA's going to love me!
Kenosee Lake, Saskatchewan, Canada


Post Posted April 16th, 2009, 8:30 pm

I have a similar problem, only I no longer have access to the previous email account. Despite the fact that I made all messages local and can read them all, I seem to be unable to copy the messages to the "Local folder" so that I can delete the account entirely (every once in a while thunderbird tries to send mail from this account (which obviously fails) and then my message gets deleted) . Any suggestions?


User avatar
Posts: 122535
Joined: September 23rd, 2004, 8:57 pm
Location: Somewhere on the right coast

Post Posted April 17th, 2009, 4:37 am

What happens when you try to move the messages? If they are not under Local Folders, how do you have them stored locally?


Post Posted June 4th, 2009, 3:56 am

In advanced settings, uncheck "Include this account when checking for new mails" (I don't remember exactly the phrase, but is something similar to that), besides unchecking "check at startup" and "check every nn seconds"

Posts: 1
Joined: June 25th, 2009, 4:00 pm

Post Posted June 25th, 2009, 4:12 pm

I have similar question ... TB is configured for 2 account - including ( POP mail server for office work and IMAP gmail server for personal ).
My office have some internet traffic constraint and no access to, this gives me HEAVY annoying alert boxes "something for connection timeout". I tried to disable IMAP per above messages:
uncheck "Check for new messages on startup"
uncheck "Check for new messages every NN minutes"
uncheck "use IDLE command if server supports it "
but the situation does improve any ! Pls help !!!

Posts: 6
Joined: April 21st, 2004, 10:01 am

Post Posted June 28th, 2009, 1:53 am

same here.

remote server can be accessed only through vpn, and logging on the vpn is lenghty and clumsy, therefore I usually do it half the times i launch thunderbird. Annoying message regarding "could not connect to server...." comes up disregarding whatever settings combination in the checkbox above mentioned.

i think this is a missing feature which can't be worked around with current application. and it would help up someone confirms this. (i can, but I count for one only. tried all options suggested, except moving all mail to local folders, but that is not "disabling" the account, rather "killing" it)

what about inserting a feature request ? how can I (we) issue a feature request ?
:P :roll:


User avatar
Posts: 122535
Joined: September 23rd, 2004, 8:57 pm
Location: Somewhere on the right coast

Post Posted June 28th, 2009, 7:20 pm

slopotich, you may be able to address your VPN issue by launching Thunderbird in off-line mode. Start Thunderbird using the Profile Manager and select "Work offline".

Posts: 57
Joined: April 22nd, 2007, 3:19 am

Post Posted July 2nd, 2009, 3:44 am

Well is there any way to suggest that as a feature - to be able to temporarily disable an account from sending/receiving messages - without deleting any of its info/settings?

Posts: 748
Joined: February 12th, 2005, 8:33 pm

Post Posted July 5th, 2009, 5:50 pm

There are a few possibilities to do what you want.

1. The "Include this server when downloading messages" (translated from French) is found under:
Tools > Account Settings > (the account) > Server Parameters > Advanced
However, it appears only when you ask the messages to be saved in the Global account.

Other possibilities...

2. Of course, disable all other automatic harvesting techniques (check at startup, every XX minutes, automatically...)

3. If you don't use a global account, download messages manually only from the account(s) you want to use. For instance, don't download (first icon on the left) from your Office account during the weekend.

4. If you have saved your password, "unsave" it. Go to:
Tools > Options (or Preferences?) > Confidentiality (4th icon) > Passwords
then click on Modify archived passwords
Then remove the password for the account you don't want to use anymore.

At that point, when you click on "Download All Messages", it won't download messages from accounts that don't have an archived password.
Michel Gagnon
Montréal (Québec, Canada)


Post Posted July 30th, 2009, 12:50 pm

Here's how to maintain an account in Thunderbird, but "disable" it so that it does not fetch messages when you click "Get Mail" (or when mail is retrieved at startup or periodically):

Tools >> Options >> Advanced >> Config Editor...

In the Filter bar, enter "server.server". Thunderbird apparently stores properties for each account under config items that have names like "server.server1", "server.server2", etc. So filtering on "server.server" will show you ALL of your accounts.

In the list, look for an item named something similar to this:
...where X above is actually a number (1,2,3,...), depending on how many accounts you have. browse through the list and look at the values of the items named ""...find the value name that corresponds to the email account you want to disable.
For example, if you discover that "" has the email address for the account you want to disable, then... the list, look for (or filter) "mail.server.server6.defer_get_new_mail" ... set this to false.

Thunderbird will no longer check that account for email.

This is obscure...but it looks like it works.

Return to Thunderbird Support

Who is online

Users browsing this forum: No registered users and 6 guests