MozillaZine

imap smtp connections refused

User Help for Mozilla Thunderbird
LukeMB
 
Posts: 25
Joined: July 22nd, 2005, 1:10 am

Post Posted March 20th, 2008, 12:19 pm

Hi there,

On my settings for Thunderbird (on a Mac Leopard) at home, I am finding it possible to receive work imap email but not to send using Thunderbird. I am having my smtp connections refused. I think the problem may be a failure to store my smtp password, but that is a guess.

1, I initially tried Thunderbird for Windows settings and they work on a Windows PC but not a Mac. I am told there is a syntactically invalid EHLO argument(s) when I try to send using the smtp server on the Mac using such settings.

2. I tried different settings recommend for Entourage but on Thunderbird instead and these give me a different error message saying that the server is refusing smtp connections. At the moment I am using Entourage successfully with these settings but would prefer to use Thunderbird. The settings are port 587, SSL, password authentication.

3. I have noticed that my smtp password is not asked for and not saved in the passwords whereas my incoming password has been asked for and is saved. Maybe this is the problem and I need to make sure my password is authenticated? That's a guess.

4, My home POP ISP mail ingoing and outgoing on port 25 is fine. My work imap email incoming is fine. It is just the work smtp sending that doesn’t work.

Incidentally I have had the same problems setting up Apple mail using the settings recommended by my work. Entourage works but I think this may be because it saves my incoming username and password for smtp whereas Thunderbrd does not seem to do this.

I thought that importing the settings from Entourage may work but when I try to import it doesn’t give Entourage as an option I can import from.

Thanks for any advice!

Luke

rsx11m
Moderator
 
Posts: 14425
Joined: May 3rd, 2007, 7:40 am
Location: US

Post Posted March 20th, 2008, 12:56 pm

LukeMB wrote:The settings are port 587, SSL, password authentication.
With port 587, try TLS rather than SSL as encryption protocol (some applications are using those terms interchangeably).

A possible solution for your "invalid EHLO argument" is to change the name of your machine (yes, you read it correctly!). Check how it is called, and if there is an underscore ('_') in it. Some SMTP servers are very picky and consider the underscore (or any other character not permitted for host names by the standard) as a syntax violation, therefore not accepting the connection.

Guest
Guest
 

Post Posted March 20th, 2008, 1:39 pm

Many thanks for the advice.

I tried TLS and TLS if available on port 587 and port 25 and that didn't work.

I looked at the computer name and got rid of hyphens and an inverted comma. Didn't work unfortunately. Someone else had mentioned the name might be a problem so that obviously is the case for some.

I wonder if the fact that I have never been asked for my smtp password and hence it has not been saved n saved passwords is the problem. So my outgoing mail is not successful because it is not authenticated. If i could enter it in the saved passwords section I wonder if that would work. I don't know how to do his without getting an alert asking for it.

Entourage did give me the option of saving my password for outgoing mail and this does work.

Luke

LukeMB
 
Posts: 25
Joined: July 22nd, 2005, 1:10 am

Post Posted March 20th, 2008, 1:42 pm

sorry, last reply was from me, I hadn't logged in.
Luke

Daifne
Moderator

User avatar
 
Posts: 123050
Joined: July 31st, 2005, 9:17 pm
Location: Where the Waters Meet, Wisconsin

Post Posted March 20th, 2008, 2:27 pm

Which SMTP server are you using from home? Some SMTP servers only allow you to use them if you are physically connected to their network. This could be the case if you are trying to use your work SMTP server from home. Try using your home ISP SMTP server if this is the case.

rsx11m
Moderator
 
Posts: 14425
Joined: May 3rd, 2007, 7:40 am
Location: US

Post Posted March 20th, 2008, 2:29 pm

LukeMB wrote:I tried TLS and TLS if available on port 587 and port 25 and that didn't work.
I looked at the computer name and got rid of hyphens and an inverted comma. Didn't work unfortunately. Someone else had mentioned the name might be a problem so that obviously is the case for some.
Ok, if the server already complains about the EHLO argument, you don't even get to the point where it would initiate encryption and ask you for your password, so that's not quite unexpected.

As for your host name, the Mac uses it as argument for you "Hello" greeting, whereas Windows uses the IP address (no clue why, it should be the same underlying code). The '-' hyphen should work, not so the '_' underscore or a '`' backquote. If restricting your host name to characters and numbers with a possible hyphen still doesn't work (you may need to reboot to make it effective for all processes), you can override the greeting explicitly as follows:
  1. Go into the Config Editor located in the Thunderbird > Preferences > Advanced > General tab.
  2. Copy-paste mail.smtpserver.smtp into the search bar.
  3. Find the entry that matches your outgoing SMTP server where you have problems with, it will have a number "smtp#" in the third component.
  4. Now you would need to right-click (you have a multi-button mouse, I hope?) in the Config Editor to select New > String from the context menu.
  5. Enter mail.smtpserver.smtp#.hello_argument as the name, replacing '#' with the number you have seen before, hit return.
  6. As the value, enter the domain of your email (e.g., something.org if your e-mail address is "abc@something.org").
  7. Hit return again and close the windows.
This will add "something.org" as argument to the EHLO greeting, then you should be able proceed to the encryption and authentication part. Make sure that you don't have any spaces in either the preference name or in its value!

See http://kb.mozillazine.org/Modify_Thunderbird_settings how to edit the prefs.js or user.js files directly if you can't create a new preference in the Config Editor (due to the lack of mouse buttons or otherwise).

P.S.: You can try Daifne's suggestion first, it seems to be somewhat easier than my list here...
Last edited by rsx11m on March 20th, 2008, 2:32 pm, edited 1 time in total.

Rod Whiteley

User avatar
 
Posts: 11480
Joined: December 6th, 2004, 3:41 am
Location: UK

Post Posted March 20th, 2008, 2:31 pm

Also look at the sending status when it fails. If the status is "Connecting..." then the only settings that apply are the server name, port and SSL.

Those other things (EHLO, TLS, password) are only sent to the server after a connection is made. So if a connection is refused, they cannot possibly be the cause.

If another program can connect from your computer using the same settings, then a "security" program on your computer is the likely cause. No other part of the system cares about which application is making the connection.
Rod

rsx11m
Moderator
 
Posts: 14425
Joined: May 3rd, 2007, 7:40 am
Location: US

Post Posted March 20th, 2008, 2:33 pm

Rod Whiteley wrote:Those other things (EHLO, TLS, password) are only sent to the server after a connection is made. So if a connection is refused, they cannot possibly be the cause.
If he is getting an EHLO argument error, the connection was established (not refused), but the server doesn't like the greeting.

Rod Whiteley

User avatar
 
Posts: 11480
Joined: December 6th, 2004, 3:41 am
Location: UK

Post Posted March 20th, 2008, 2:40 pm

Yes, it would be good to know whether the connection was really refused. Perhaps Luke can reply telling us the exact error message, and the name of the server.
Rod

LukeMB
 
Posts: 25
Joined: July 22nd, 2005, 1:10 am

Post Posted March 20th, 2008, 6:33 pm

Thanks everyone, much appreciated.

First of all I am using my workplace smtp server at work, a university, from home. Using Entourage from my mac or Thunderbird on my windows pc to do that works fine. So I don't think it is the work server that is the problem.

Unfortunately my ISP smtp server won't allow me to send through it with my work email address. It says it only allows local addresses.

The Ehlo message was when I was using Port 25 and TLS. Entourage on the mac works with 578 and ssl so I have tried that on thunderbird. This is what seems to be recommended and what works with Entourage. The error message in this case was that the smtp connection failed or was refused and I should check my settings or check with my mail administrator. I can't remember he exact words because now it has changed - it just gets stuck at 'connecting'.

rsx - I tried the config editor solution, thanks for that, I can right-click, and whether I send after this with port 25/tls or 587/ssl it just sticks at connecting to the smtp server.

I have emailed my email administrator at work but they are away for Easter and I suspect they won't be able to help as they don't support Thunderbird.

Can I use config editor to enter my work smtp password so that authentication happens?

Im, not sure what security programmes I have on a mac. The firewall is turned on but otherwise there is no ant-virus etc.

Luke

LukeMB
 
Posts: 25
Joined: July 22nd, 2005, 1:10 am

Post Posted March 20th, 2008, 6:44 pm

When in the config editor I noticed that the value given for my work smtp started with 'mail' not 'smtp'. So I changed it to start with smtp. When I did this and then sent I got the message that I was connected but that sending of message failed because connecting to he smtp server failed, it is unavailable or is refusing connections, verify that your sever setting is correct and try again, or contact your network administrator.

LukeMB
 
Posts: 25
Joined: July 22nd, 2005, 1:10 am

Post Posted March 20th, 2008, 6:56 pm

I've solved it. I changed the value as mentioned above to smtp. I then noticed in the settings that my outgoing server was listed as mail sever rather than smtp server. I can't understand how that happened. Maybe the hello greeting in combination with these also did the trick. It then asked me for my sending password which I saved. Many thanks, for your advice, and sorry that it was such an obvious thing I should have spotted.

LukeMB
 
Posts: 25
Joined: July 22nd, 2005, 1:10 am

Post Posted March 21st, 2008, 4:18 am

I looked through all the steps I went through.

Through most of the process the work sending server was listed as smtp but then changed to mail in the last stages. Maybe something to do with the config editor changes. So I don't think that was the issue.

I think it was the hello argument change that did it. When that was added it proceeded to authentication. So thanks rsx and others.

cheers.

rsx11m
Moderator
 
Posts: 14425
Joined: May 3rd, 2007, 7:40 am
Location: US

Post Posted March 21st, 2008, 5:59 am

You are welcome, glad to hear that it works now. The server name shouldn't have changed just because you added the greeting, or you might have seen other preferences showing up that match the filter I gave you. I agree that likely the correct greeting allowed you to proceed to encryption and password authentication, thus you could resolve the other issues then. Port 587 with SSL (not TLS) gave you the error because the wrong encryption protocol was negotiated, I'm not sure if "connection refused" is a good error message to indicate that.

LukeMB
 
Posts: 25
Joined: July 22nd, 2005, 1:10 am

Post Posted March 21st, 2008, 11:52 am

Yes, agree with all you say. I passed your solution on to our work IT people in case anyone else has the same problem.

Return to Thunderbird Support


Who is online

Users browsing this forum: No registered users and 5 guests