MozillaZine

Daily Build Thread 2008-03-26 Through 2008-04-01

Discussion about official Mozilla Thunderbird builds
JoeS

User avatar
 
Posts: 2337
Joined: June 8th, 2003, 9:15 am

Post Posted March 26th, 2008, 3:20 pm

Daily Build Thread
Please use the next Daily Build Thread
[If you would like to volunteer to post this weekly thread on a rotational basis
Please go here: http://wiki.mozilla.org/Thunderbird:Nig ... ld_Threads for further instructions.]

Links
ImageRSS feed Compliments of FB|PuppetMaster..Thanks
Update Watch (Courtesy of Nick Thomas)
Latest-Trunk_ en-US l10n
Latest-Branch en-US l10n

Checkins This Week

[2008-03-26 09:24 -trunk ]# 336615 [Core] - shouldn't use magic numbers for junk status [All]
[2008-03-26 09:45 -trunk ]# 410333 [Core] - get rid of the send in utf-8 question-dialog, just silently switch to utf-8 if necessary [All]
[2008-03-26 09:49 -trunk ]# 424756 [Thunderbird] - [Mac] If there's an open about window, activate it on Thunderbird->About Mozilla Thunderbird [Mac]
[2008-03-26 15:22 -trunk ]# 408335 [Thunderbird] - UI for Option "Apply default character encoding to all incoming messages" should be removed [All]
[2008-03-28 01:41 -trunk ]# 359255 [Thunderbird] - Importers: Import Filters from current Eudora [All]
[2008-03-28 02:00 branch]# 90584 [Core] - charset=... must be applied to non-MIME Subject:/From:/To:/etc. fields [All]
[2008-03-28 11:59 -trunk ]# 422800 [Core] - Implement nsIAbManager::directories attribute [All]
[2008-03-29 13:40 -trunk ]# 422800 [Core] - Implement nsIAbManager::directories attribute [All]
[2008-03-31 18:27 -trunk ]# 413651 [Core] - Fix "unused variable" compiler warnings [Mac]
[2008-03-31 18:30 -trunk ]# 422572 [Core] - Remove nsSmtpDelegateFactory [All]
[2008-03-31 18:44 -trunk ]# 253403 [Thunderbird] - compose window doesn't remember the size of "contacts" panel [Win]
[2008-03-31 19:57 -trunk ]# 421846 [Thunderbird] - Clean up Thunderbird's compose global scope [All]
[2008-04-01 01:39 -trunk ]# 418551 [Core] - Convert panacea.dat from mork [All]
[2008-04-01 07:46 -trunk ]# 426320 [Core] - nsIAbDirFactoryService::getDirFactory should take an ACString as an arg rather than a "string" [All]
[2008-04-01 20:32 -trunk ]# 425825 [Thunderbird] - offline dialog checkboxes can't be (un)ticked [All]

Recent Bugs of interest

# 353205 [Thunderbird] - request way to set default to no alternate text for inserting images [Win]
# 415601 [Core] - Mailnews topcrashes [@ nsUInt32Array::GetAt] [@ nsMsgDBView::NonDummyMsgSelected] [All]
# 425825 [Thunderbird] - offline dialog checkboxes can't be (un)ticked [All]
# 425950 [Core] - Thunderbird fails to start after updating to 20080329 nightly build [@ js_SweepScopeProperties][@ JS_CallTracer] [All]

Latest Tested Builds

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9pre) Gecko/2008033002 Thunderbird/3.0a1pre ID:2008033002


Current "Gotchas" for Trunk Testers

Since 2007-08-13 You will need to "select" an app to call a link.
This is stored in mimeTypes.rdf but is not editable in the TB UI
Workaround: Don't save the selection, or backup your mimetypes.rdf.

Current Branch Status

Green
Last edited by JoeS on April 2nd, 2008, 3:19 pm, edited 7 times in total.
JoeS Testing current Thunderbird trunk builds WinXP SP2+
news://news.mozilla.org.mozilla.test.multimedia How to Post

Scanorama
Folder@Home
 
Posts: 740
Joined: April 15th, 2005, 7:49 pm
Location: Melbourne, Australia

Post Posted March 29th, 2008, 5:21 am

The 0329 nightly trunk build for Windows does not start. After updating from 0328 to the new build, it crashed. When I clicked on Thunderbird, nothing happened. thunderbird.exe appeared in the Task Manager briefly then disappeared. I'm using Windows Vista by the way.

Is this a new bug?


Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9pre) Gecko/2008032902 Thunderbird/3.0a1pre ID:2008032902

br00dy
 
Posts: 24
Joined: August 9th, 2006, 12:25 am

Post Posted March 29th, 2008, 5:35 am

Same problem here as well using Vista

JoeS

User avatar
 
Posts: 2337
Joined: June 8th, 2003, 9:15 am

Post Posted March 29th, 2008, 6:16 am

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9pre) Gecko/2008032902 Thunderbird/3.0a1pre ID:2008032902

Seems to be OK in Winxp

EDIT: Possibly caused by,
[2008-03-29 00:19 -trunk ]# 412374 [Firefox] - Download Mgr bypasses Vista Parental Controls' file-blocking flag [Win]
JoeS Testing current Thunderbird trunk builds WinXP SP2+
news://news.mozilla.org.mozilla.test.multimedia How to Post

oorwullie

User avatar
 
Posts: 468
Joined: September 20th, 2005, 9:37 am
Location: Belfast NI

Post Posted March 29th, 2008, 7:08 am

Naw! It's happening in Win XP here. had to revert to yesterday's build.
SM, TBird & FF trunk nightlies; Win 8.1/Ubuntu; Apache OOo 4
============================================

toscha42

User avatar
 
Posts: 448
Joined: December 15th, 2005, 3:23 pm
Location: Munich

Post Posted March 29th, 2008, 7:44 am

Scanorama wrote:The 0329 nightly trunk build for Windows does not start. After updating from 0328 to the new build, it crashed. When I clicked on Thunderbird, nothing happened. thunderbird.exe appeared in the Task Manager briefly then disappeared. I'm using Windows Vista by the way.

Is this a new bug?
Obviously, at least it didn't occur yesterday. :)

And it occurs also with today's build under Windows XP, Thunderbird simply does not start at all.

<b>[Edit]</b>
After several starts (clean profile, safe-mode with standard profile) today's nightly build finally starts again.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9pre) Gecko/2008032902 Thunderbird/3.0a1pre ID:2008032902
<b>[/Edit]</b>

Ciao
Toscha
Last edited by toscha42 on March 29th, 2008, 7:55 am, edited 1 time in total.

JanT
 
Posts: 135
Joined: March 18th, 2004, 4:45 pm
Location: Eindhoven, NL

Post Posted March 29th, 2008, 7:54 am

Thunderbird won't start.
Made a new, empty profile and its runs.
Copying the settings from the old to the new profile in several steps and it keeps running.
The same after installing the extensions.

Mozilla/5.0 (Windows; U; Windows NT 5.0; nl; rv:1.9pre) Gecko/2008032902 Thunderbird/3.0a1pre ID:2008032902

JoeS

User avatar
 
Posts: 2337
Joined: June 8th, 2003, 9:15 am

Post Posted March 29th, 2008, 8:57 am

Well, I wonder why I had no problems here.
Some possibilities:

I skipped the 28th partial, so my update was a "full" from the 27th to the 29th

A while back, I installed the VC+ redist package from MSDN, which added some missing components.
JoeS Testing current Thunderbird trunk builds WinXP SP2+
news://news.mozilla.org.mozilla.test.multimedia How to Post

DaveLewis
 
Posts: 42
Joined: November 10th, 2002, 12:26 am
Location: Tigard, OR

Post Posted March 29th, 2008, 9:08 am

I downloaded the zip file (Win32) and installed it using my existing profile and it works okay so far.

supernova_00
 
Posts: 4832
Joined: June 24th, 2004, 8:03 pm
Location: Maryland, USA

Post Posted March 29th, 2008, 9:11 am

Also won't start here on xp. It did start at one time, crashed and a report was submitted. crash report. Don't know if that is related though.

Edit: Filed Bug# 425950 - Firefox fails to start after updating to 20080329 nightly build

KennS

User avatar
 
Posts: 153
Joined: October 23rd, 2006, 9:13 pm

Post Posted March 29th, 2008, 6:44 pm

I had today's - the 29th - nightly up and running after the update. Then it crashed and wouldn't restart. my comp slowed down humungously - so I restarted it and still no joy with today's nightly.

Ran TBV2 and it did the extension compatibility check and ran ok. Shut it down and retried V3. Lo and behold it started up - did the compatibility check and ran.

Shut it down and restarted and all is good - so far.

Kenn
--
from the bottom of the rockpile

JoeS

User avatar
 
Posts: 2337
Joined: June 8th, 2003, 9:15 am

Post Posted March 29th, 2008, 7:01 pm

KennS
If you are running both builds from the same profile (which is generally not a good thing)
Since this bug is somehow profile related, you could be bypassing the problem.
JoeS Testing current Thunderbird trunk builds WinXP SP2+
news://news.mozilla.org.mozilla.test.multimedia How to Post

Scanorama
Folder@Home
 
Posts: 740
Joined: April 15th, 2005, 7:49 pm
Location: Melbourne, Australia

Post Posted March 30th, 2008, 4:36 am

0330 nightly starts up with no problem.

Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9pre) Gecko/2008033002 Thunderbird/3.0a1pre ID:2008033002

niol
 
Posts: 1
Joined: March 30th, 2008, 4:42 am

Post Posted March 30th, 2008, 4:57 am

JanT wrote:Thunderbird won't start.
Made a new, empty profile and its runs.
Copying the settings from the old to the new profile in several steps and it keeps running.
The same after installing the extensions.

Mozilla/5.0 (Windows; U; Windows NT 5.0; nl; rv:1.9pre) Gecko/2008032902 Thunderbird/3.0a1pre ID:2008032902


Same problem and solution here [Mozilla/5.0 (X11; U; Linux i686 (x86_64); en-US; rv:1.9pre) Gecko/2008032903 Thunderbird/3.0a1pre ID:2008032903 ]

Start with a new pofile, then copy prefs.js, key3.db, cert8.db and ImapMail directory.
TB is now runing fine.

KennS

User avatar
 
Posts: 153
Joined: October 23rd, 2006, 9:13 pm

Post Posted March 31st, 2008, 1:31 am

JoeS wrote:KennS
If you are running both builds from the same profile (which is generally not a good thing)
Since this bug is somehow profile related, you could be bypassing the problem.


Yes, I realize that it isn't necessarily a wise thing to run both versions with the same profile. However, I so infrequently run Version 2 that I don't think it is an issue. The last time I ran version two was about 2 months ago. V3 is my primary email program, I know that is risky, but there have been very few issues with it that have caused my any grief.

KennS
--
from the bottom of the rockpile

Return to Thunderbird Builds


Who is online

Users browsing this forum: No registered users and 0 guests