MozillaZine

Daily Build Thread 2008-04-02 Through 2008-04-08

Discussion about official Mozilla Thunderbird builds
JoeS

User avatar
 
Posts: 2337
Joined: June 8th, 2003, 9:15 am

Post Posted April 2nd, 2008, 3:22 pm

Daily Build Thread
Please use the next Daily Build Thread
[If you would like to volunteer to post this weekly thread on a rotational basis
Please go here: http://wiki.mozilla.org/Thunderbird:Nig ... ld_Threads for further instructions.]

Links
ImageRSS feed Compliments of FB|PuppetMaster..Thanks
Update Watch (Courtesy of Nick Thomas)
Latest-Trunk_ en-US l10n
Latest-Branch en-US l10n

Checkins This Week

[2008-04-02 00:37 -trunk ]# 420614 [Core] - Drop nsAdapterEnumerator [All]
[2008-04-02 04:46 -trunk ]# 426317 [Core] - Drop nsIAbMDBDirectory::getDirUri [All]
[2008-04-03 16:48 -trunk ]# 424024 [Thunderbird] - Can't delete folders without a msgWindow and a confirmation [Mac]
[2008-04-03 16:50 -trunk ]# 426715 [Thunderbird] - can't open new composition window anymore ("An error occurred while creating a message compose window. Please try again." [All]
[2008-04-03 20:51 -trunk ]# 425015 [Thunderbird] - Customize Toolbar Menu doesn't work anymore [Mac]
[2008-04-04 15:23 branch]# 426307 [mozilla.org] - Tracking bug for Build and Release of FF2.0.0.14 [All]
[2008-04-06 05:28 -trunk ]# 394114 [Core] - Interfaces missing from various QI implementations. [All]
[2008-04-06 16:31 -trunk ]# 11054 [Core] - Ignore (kill) a Subthread (branch: not the whole thread) (Troll) [All]
[2008-04-06 16:41 -trunk ]# 426947 [Thunderbird] - "assignment to undeclared variable server" opening filter dialog [All]
[2008-04-07 13:12 -trunk ]# 363980 [Thunderbird] - Change context-menu text for Create Filter function [All]
[2008-04-08 00:48 -trunk ]# 427534 [Core] - Tidy up the Address Book unit tests [All]
[2008-04-08 13:30 -trunk ]# 365842 [Thunderbird] - Title bar displays email address rather than Account name [All]

Recent Bugs of interest

# 353205 [Thunderbird] - request way to set default to no alternate text for inserting images [Win]
# 415601 [Core] - Mailnews topcrashes [@ nsUInt32Array::GetAt] [@ nsMsgDBView::NonDummyMsgSelected] [All]
# 425950 [Core] - Thunderbird fails to start after updating to 20080329 nightly build [@ js_SweepScopeProperties][@ JS_CallTracer] [All]
# 418551 [Core] - Convert panacea.dat from mork [All]
# 426658 [Thunderbird] - Long delay when getting new mail [Win]
# 427614 [Core] -increased memory usage on TB startup of 100-120MB ....,and 100% cpu[Win]
# 427880 [Thunderbird] - Compose features disabled after using plain text editor [Win]

Latest Tested Builds

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9pre) Gecko/2008033002 Thunderbird/3.0a1pre ID:2008033002


Current "Gotchas" for Trunk Testers

Since 2007-08-13 You will need to "select" an app to call a link.
This is stored in mimeTypes.rdf but is not editable in the TB UI
Workaround: Don't save the selection, or backup your mimetypes.rdf.

Current Branch Status

Green
Last edited by JoeS on April 9th, 2008, 4:12 pm, edited 12 times in total.
JoeS Testing current Thunderbird trunk builds WinXP SP2+
news://news.mozilla.org.mozilla.test.multimedia How to Post

JoeS

User avatar
 
Posts: 2337
Joined: June 8th, 2003, 9:15 am

Post Posted April 2nd, 2008, 6:02 pm

Filed # 426658 [Thunderbird] - Long delay when getting new mail [Win]
JoeS Testing current Thunderbird trunk builds WinXP SP2+
news://news.mozilla.org.mozilla.test.multimedia How to Post

jugg
 
Posts: 6
Joined: August 27th, 2004, 12:13 pm

Post Posted April 7th, 2008, 2:54 pm

The newsgroups keeps loosing my password after a period of time. It will first popup a dialog (which is filled in) asking for the username then popup a dialog (which is blank) asking for the password.

If I fill the data in, it'll continue to work for a while, and then at some point forget, and ask again.

I'm using: version 3.0a1pre (2008040703)

I've been using these builds for a while now, and this only started showing up today. Although I hadn't updated since mid last week.

JoeS

User avatar
 
Posts: 2337
Joined: June 8th, 2003, 9:15 am

Post Posted April 7th, 2008, 5:51 pm

jugg wrote:The newsgroups keeps loosing my password after a period of time. It will first popup a dialog (which is filled in) asking for the username then popup a dialog (which is blank) asking for the password.

If I fill the data in, it'll continue to work for a while, and then at some point forget, and ask again.

I'm using: version 3.0a1pre (2008040703)

I've been using these builds for a while now, and this only started showing up today. Although I hadn't updated since mid last week.


I think what you are seeing is normal if you are experiencing "connection problems"
Here is a summary of how things should work, it fits your description of what you are seeing.
# 286628
JoeS Testing current Thunderbird trunk builds WinXP SP2+
news://news.mozilla.org.mozilla.test.multimedia How to Post

jugg
 
Posts: 6
Joined: August 27th, 2004, 12:13 pm

Post Posted April 8th, 2008, 9:02 am

JoeS wrote:
jugg wrote:The newsgroups keeps loosing my password after a period of time. It will first popup a dialog (which is filled in) asking for the username then popup a dialog (which is blank) asking for the password.

If I fill the data in, it'll continue to work for a while, and then at some point forget, and ask again.

I'm using: version 3.0a1pre (2008040703)

I've been using these builds for a while now, and this only started showing up today. Although I hadn't updated since mid last week.

I think what you are seeing is normal if you are experiencing "connection problems"
Here is a summary of how things should work, it fits your description of what you are seeing.
# 286628

Hmm, it could be. If it occurs again, I'll try to notice exactly what steps happen.

Even so, I don't see how that issue is marked as fixed. The behavior is completely annoying. If there is a connection issue, or even a simple incorrect password failure, it should retry for x amount of times, then stop trying. Some sort of unabtrusive notification (like the popups that say new mail has arrived, which could contain links to 'retry or change password') that doesn't steal focus stating that "authentication has failed, no more retries left; you must manually reconnect". That would be a "correct" solution. But losing the user/password and continuing to retry connecting and tossing up dialog prompts is pointless.

I absolutely dislike dialog boxes that appear outside the normal work flow. The fact that they are still employed in "modern" programs amaze me. ohwell.. getting off topic. :)

jugg
 
Posts: 6
Joined: August 27th, 2004, 12:13 pm

Post Posted April 8th, 2008, 10:26 am

Today I noticed that my "Drafts" folder in "Local Folders" showed that there were two "unread" messages in the folder (the folder was bold, and had '2' next to it). When selecting the folder to view the contents, no messages appeared in the message list pane. Opening up the "Drafts" file in my profile showed pretty much every message I have posted to newsgroups. So I went back to Thunderbird, and selected "Compact Folders". Immediately the two "unread" messages showed up in the message list pane, and the "Drafts" file was reduced to only include those two messages.

Unfortunately I hadn't backed up the profile prior to doing this, so I don't have the data set to reproduce the problem.

version 3.0a1pre (2008040703)

Return to Thunderbird Builds


Who is online

Users browsing this forum: No registered users and 2 guests