MozillaZine

The Official Win32 20080430 [Trunk] build is out.

Discussion about official Mozilla Firefox builds
Peter(6)

User avatar
 
Posts: 13011
Joined: September 4th, 2003, 1:26 am
Location: Maassluis, The Netherlands

Post Posted April 29th, 2008, 9:12 am

The Official Win32 20080430 [Trunk] build is out.

Previous nightly 20080429

Hourly Trunk builds:
fx-linux-tbox-trunk (Lin) || XSERVE08 (Mac) || FX-WIN32-TBOX-trunk (Win) || Trunk Tinderbox || Trunk Bonsai
Hourly Builds Archive: Linux, Mac and Windows

Last update: 2008-04-30 -- 08:10 PDT = 15:10 UTC (all check-ins since the latest nightly included)
The tree is LOCKED for FF3.0 RC1

Fixed:
  1. #402798[Firefox:Places]-Periodically the bookmarks top level flyout menus go missing [Mac]
  2. #402799[Firefox:Places]-Saved searches that match on tags show duplicates [All]
  3. #406894[Firefox:Location Bar and Autocomplete]-Icons in the location bar and search bar need hover and depressed states (web feed)(star)(location bar)(bookmarks) [All]
  4. #408860[Firefox:Places]-Library forward button broken and back button toggles last two selected items [All]
  5. #409427[Core:XP Toolkit/Widgets: Menus]-Status bar tooltips only flash up on mouse-pointer hover [All]
  6. #411064[Toolkit:XUL Widgets]-iconic menu items are 2px higher than normal ones [Win]
  7. #416728[Firefox:Theme]-update pinstripe for bug 414366 [Mac]
  8. #421180[Firefox:Places]-When removing bookmarks existing keywords aren't deleted/removed [All]
  9. #421468[Core:XForms]-[1.1] Support @resource on instance element [Win]
  10. #426499[Core:Widget: Cocoa]-[10.5] Crash opening Help menu [@ DrawTheMenu(MenuSelectData*, __CFArray**, unsigned char, unsigned char*)] [Mac]
  11. #427045[Core:Widget: Win32]-Pull out correct toolbar colors in Vista themes [Win]
  12. #427106[Core:XForms]-Insert action only inserts first node from origin node-set [Lin]
  13. #428349[Firefox:Theme]-In Addon Manager, the (x) that closes the "No updates were found" message is shifted a bit to the left inside its small box [Lin]
  14. #428600[Core:File Handling]-console spam from nsIHandlerService [All]
  15. #429252[Core:JavaScript Engine]-trap changes decompilation of "{ let x }" [Mac]
  16. #429281[Core:JavaScript Engine]-JS_SetTrap does not unroot a fresh trap before calling free on it [All]
  17. #430079[Toolkit:XUL Widgets]-Remove some ancient style rules from dialog.css [Mac]
  18. #430276[Core:DOM]-new XMLHttpRequest() after document.write throws an exception [All]
  19. #430351[Core:Plug-ins]-unable to fill certain flash forms with recent camino nightly builds [Mac]
  20. #430506[Core:Widget: Cocoa]-Firefox crash on Exit when the Adblock Plus Pref Window is open [Mac]
  21. #430552[Core:XPConnect]-Browsing on the given site and closing the tab results in no active tab and keyboard shortcuts don't work until you refocus any element [All]
  22. #430650[Core:Widget: Gtk]-'^' and '¨' chars don't work in password fields [Lin]
  23. #430714[Firefox:Theme]-Move the identity contextual dialog up to avoid double line [Win]
  24. #430748[Core:Printing]-Print-selection places text too low, with initial whitespace and select-all [Lin]
  25. #430948[Firefox:Places]-Places:Drag & Drop a Favicon or a Link to Bookmarks Toolbar, Bookmarks Menu or Sidebar Bookmarks does not work. [All]
  26. #430975[Firefox:General]-app-license.html is missing closing </p> [All]
  27. #430998[Core:Widget: Win32]-Text in buttons should not shift on down press on Luna or Aero [Win]
  28. #431408[Core:Disability Access APIs]-Rename cell-index string property to table-cell-index [All]
  29. #431013[Core:Networking]-FTP view is not using new folder icons on XP and Vista [Win]
  30. #431231[Firefox:Places]-Unable to save RSS feed to anything but the bookmarks toolbar (UI missing?) [All]
  31. #431241[Firefox:Theme]-Use a solid line between results in the error console [Win]
  32. #431275[Toolkit:XUL Widgets]-Give notification bars default icons via CSS [All]
  33. #431428[Core:JavaScript Engine]-Crash [@ js_GetSrcNoteOffset] with for..in, trap [All]

Partial Landings/WIPs/Incoming:
  1. #429510[Core:Widget]-Web apps cannot handle Ctrl+foo/Alt+foo key on keypress event [All]
  2. #430873 BACKOUT[Core:Layout: Canvas]-fast-path drawImage with a canvas as source [All]

Regressions/Annoying/Common bugs:
  1. #422308[Toolkit:Breakpad Integration]-Breakpad does not catch crash when flash plugin is active [Win]

To copy your useragent+buildtime to clipboard, use the Nightly Tester Tools extension.
Get more out of the Javascript Console, see this page for Console²
If you're a daily tester then backup the valuable data in your profile !

Trunk fixes since branching for 1.5 (20050812) = ~ 14,816

Roadmap: Firefox 3.0 RC1 [200804],....Firefox 3.0 [200806]
Gran Paradiso Milestones: 3.0b5(20080402 ~14,183), 3.0b4(20080310 ~13,646), 3.0b3(20080212 ~12,986), 3.0b2(20071221 ~12,169), 3.0b1(20071120 ~11,630), 3.0a8(20070920 ~10,640), 3.0a7(20070803 ~9,820), 3.0a6(20070703 ~9,350), 3.0a5(20070607 ~8,940), 3.0a4(20070427 ~8,350), 3.0a3(20070323 ~7,930), 3.0a2(20070208 ~7,450), 3.0a1(20061208 -6,750)

If you want bugs to be fixed, find the regressionwindow.
If you want the regressionwindow, download hourly builds and test them.
It really makes a difference if you do.

IRC channels: #firefox || #bugs
Last edited by Peter(6) on April 30th, 2008, 9:27 am, edited 3 times in total.

Fedorov
 
Posts: 211
Joined: January 27th, 2004, 3:20 am

Post Posted April 29th, 2008, 11:16 am

polidobj wrote:
Fedorov wrote:Thanks Blisk, here are the url's:
http://crash-stats.mozilla.com/report/i ... 1321b13766
http://crash-stats.mozilla.com/report/i ... 13211cbf8a

It is worrying that we are not seeing more about this - I've had the early alpha/beta versions running with ZERO crashes for months now but ever since the bad builds from 15th April which got "fixed" a few days later they are still not as stable and I believe still crashing on flash sites.
The bug for this isn't going anywhere without a reproducable way to crash.
#429442[Core:XPConnect]-crashes [@ nsJSIID::HasInstance][@ XPCNativeSet::FindInterfaceWithIID] [All]
OK. Well, I'll add it to the blocker list, but if we can't find a way to reproduce and fix, it's going to fall off.
I browsed around lifehacker with a clean profile for about five minutes going from page to page and no crash.


Okay, you set me a challenge and I've tried all sorts and I'm now able to reproduce this crash 99% of the time...

Can you/everyone please give the following steps a try MULTIPLE TIMES to see if it will crash for anyone else???...

1) Load Firefox 3.0 fresh to ensure you are starting clean
2) In your 1st tab go to: http://cybernetnews.com/
3) Wait till this tab has fully loaded (throbber stopped)
4) CTRL-T to open a 2nd tab and go to http://lifehacker.com/
5) Wait till this tab has fully loaded (throbber stopped)
6) Hit CTRL-R to RELOAD the lifehacker tab and immediately (while still reloading lifehacker) click your 1st (cybernetnews) tab and also hit CTRL-R to RELOAD cybernetnews
7) WAIT until BOTH TABS have finished reloading!
8) Now click back onto the 2nd (lifehacker) tab and Firefox will crash!!!
9) If it does not crash then REPEAT the above from step no. 6

So far I have gone through this cycle 4 times, and on 3 occasions after the reloads, the point of the crash is when you click on the lifehacker tab, you see the page for a split second and then you get the crash. My 4th attempt I had to repeat the above as per step 9 and it crashes on the 2nd time through.

After posting this I'm going to carry on crashing it this way to prove it is consistently crashing, I shall then try disabling Adblock and also NoScript to see if any difference is noticed...

Appreciate if anyone else can carefully follow the above steps and reproduce this to get it sorted!!! :)

Regards

Fedorov.

Pennington99
 
Posts: 415
Joined: October 16th, 2006, 2:21 pm
Location: Virginia

Post Posted April 29th, 2008, 11:40 am

Stable for me

Vista SP1 (Adblock plus, NoScript etc etc)

lrombes

User avatar
 
Posts: 100
Joined: April 14th, 2006, 10:59 am
Location: Toledo, OH

Post Posted April 29th, 2008, 11:50 am

Sorry, I cannot repeat this crash either. It works fine for me.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9pre) Gecko/2008042906 Minefield/3.0pre ID:2008042906

szhorvat
 
Posts: 208
Joined: November 3rd, 2005, 12:42 pm

Post Posted April 29th, 2008, 12:15 pm

From yesterday:
szhorvat wrote:Something is very wrong with how some special characters are rendered in this page. Compare the rendering in Fx2 and Fx3:

Image

Is this a (known) bug?

EDIT: Can anyone else reproduce the problem? The special characters are in the 2nd and 3rd rows starting with "print".


Toscha and Louise posted screenshots showing that the rendering is fine for them on Windows and Mac.

Now I found out what causes the misrendering on my computer. It is the STIX fonts. Removing them fixes the problem (the redering will be the same as on the screenshot posted by Toscha).

Since the STIX fonts are practically required for anyone who uses Fx3 to view MathML content, this is still a buggy behaviour that should not occur. What I do not know is whether the bug is in Firefox or the fonts. Is it worth filing a bug for this? (Fx2 did handle certain fonts in a special way, to be able to display MathML properly. I don't know if this is still the case for Fx3.)

EDIT: I'm on Windows:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9pre) Gecko/2008042906 Minefield/3.0pre ID:2008042906

Pennington99
 
Posts: 415
Joined: October 16th, 2006, 2:21 pm
Location: Virginia

Post Posted April 29th, 2008, 12:41 pm

Not that I know anything about ALGOL, but I believe I am seeing it as it should be (as per FF 2 example given above) using Vista SP1 and the latest nightly.

szhorvat
 
Posts: 208
Joined: November 3rd, 2005, 12:42 pm

Post Posted April 29th, 2008, 12:48 pm

@Pennington99:

As I said, the problem is only present if you have the STIX fonts installed. ( http://www.aip.org/stixfonts/ ) These fonts are required for proper MathML display in Fx3. Unfortunately they are not available any more from the website I mentioned (they are preparing for the final release), so I cannot point to a download link ... I think that they can be downloaded somewhere on mozilla's website but I couldn't find where exactly ... (IIRC there was a link from a bugzilla page ...)

Fedorov
 
Posts: 211
Joined: January 27th, 2004, 3:20 am

Post Posted April 29th, 2008, 12:49 pm

Pennington99 wrote:Stable for me

Vista SP1 (Adblock plus, NoScript etc etc)


Thanks for trying - I've managed to narrow this down... obviously the content of lifehacker has changed since my posting so I've found a specific article that *was* on their frontpage earlier and using this page and repeating my steps above will crash just by repeating my steps 2 or 3 times.

So, instead of lifehacker.com on the 2nd tab, please try: http://lifehacker.com/384795/palbee-doe ... nferencing

NoScript BLOCKS the embedded video and repeating my steps will cause a crash.

If I disable NoScript I can repeat my steps as many times as I wish and it will NOT crash - yipeeee. NoScript is the culprit for this one!

Pennington99
 
Posts: 415
Joined: October 16th, 2006, 2:21 pm
Location: Virginia

Post Posted April 29th, 2008, 1:02 pm

Crash - and no crash if NoScript disabled

Fedorov
 
Posts: 211
Joined: January 27th, 2004, 3:20 am

Post Posted April 29th, 2008, 1:53 pm

Pennington99 wrote:Crash - and no crash if NoScript disabled


YAY! Let's have more reproducing this crash please :)

Warduke
 
Posts: 630
Joined: November 4th, 2002, 7:49 pm

Post Posted April 29th, 2008, 2:19 pm



This link crashes me every now and then. I have Flashblock (1.5.6a) and when I click on the placeholder, it crashes. It seems to be completely random as to when it happens. The first time I went there, it crashed. The second time I had to reload it five times for it to crash. Then tried reloading it thirty times, no crash. Most times it seems that several reloads will cause a crash. After disabling Flashblock, I couldn't get it to crash.

On a different (possibly related) note, is anyone else using Flashblock having issues with clicking on the placeholder and it reloads the placeholder? After clicking on it for a second time, the video doesn't load. Reloading the page usually fixes it.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9pre) Gecko/2008042906 Minefield/3.0pre
Firefox : One Browser to Rule Them All.

trolly
Moderator

User avatar
 
Posts: 39908
Joined: August 22nd, 2005, 7:25 am

Post Posted April 29th, 2008, 2:32 pm

http://www2.glamour.de/glamour/glamunit ... um.php?f=1

Crashes completely random for me. On WXP more, on W2K less. NoScript?
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9pre) Gecko/2008042906 Minefield/3.0pre ID:2008042906
Think for yourself. Otherwise you have to believe what other people tell you.
A society based on individualism is an oxymoron. || Freedom is at first the freedom to starve.
Constitution says: One man, one vote. Supreme court says: One dollar, one vote.

earlpiggot

User avatar
 
Posts: 712
Joined: May 30th, 2004, 2:40 pm
Location: Greece

Post Posted April 29th, 2008, 2:34 pm

has it been reported that drag'n'drop does not work for bookmarks again?

Warduke
 
Posts: 630
Joined: November 4th, 2002, 7:49 pm

Post Posted April 29th, 2008, 2:38 pm

earlpiggot wrote:has it been reported that drag'n'drop does not work for bookmarks again?


https://bugzilla.mozilla.org/show_bug.cgi?id=430948
Firefox : One Browser to Rule Them All.

a;skdjfajf;ak

User avatar
 
Posts: 17002
Joined: July 10th, 2004, 8:44 am

Post Posted April 29th, 2008, 2:38 pm

earlpiggot wrote:has it been reported that drag'n'drop does not work for bookmarks again?


Yes, bug: https://bugzilla.mozilla.org/show_bug.cgi?id=430948 fix has been checked in in last couple hrs.

Return to Firefox Builds


Who is online

Users browsing this forum: Google [Bot], hurra123 and 6 guests