MozillaZine

printer won't print websites

User Help for Mozilla Firefox
blueflyer
 
Posts: 3
Joined: May 19th, 2008, 10:12 pm

Post Posted May 19th, 2008, 10:34 pm

I am posting all previous messages so you know what has been already done.

Original message: sent to Lexmark
I have Lexmark Z1300 printer, Windows XP, Mozilla Firefox

Up until a few weeks ago when I was going to print something off the internet I would pull up print preview to see how it would look. Now I always get a blank page and it prints as a blank page. I have tried highlighting the information and same thing. I have to copy and paste to
Microsoft Word to print off.
I don't know if this is a printer problem or something to do with the hard drive. I ran an update on the Lexmark and did spyware checks with spybot and everything seems to be ok there.

Lexmark REPLY:

Thank you for using our electronic support to assist you with this issue.

You may have to change the communication format called the "Spool format."

Please follow the steps given below to change the spool data format:

1. Click on "Start," "Control Panel," "Printers and Other Hardware" and "Printers and Faxes."
2. Then, right click on the Lexmark printer icon and left click "Properties."
3. Either on the "Advanced" tab or the "General" tab for some models,
there is a "Print Processor" button, left click it.
4. This is the spool format setting. Under "Print processor" it should be set to "Lexmark 1300 series print processor." Next, under "Default datatype," select "NT EMF 1.008."
5 . Click "OK" and exit back out to your desktop.
6. Please try printing again.

If this does not help the situation, I suggest you to try printing from internet using a different web browser like Internet Explorer and let us please know the result. This information is important for us to
assist you further.

ME: I followed your instructions and it still doesn't print the webpage, which, by the way, is the one below. I reinstalled IE7 and it printed out. I have had this printer for about 6 months and it has not had any problems printing on Mozilla until about 2 weeks ago. I do not want to use IE7 as my browser, I want Mozilla. So what is happening and what do I do.

Lexmark REPLY:
I suggest you to download the Firefox version of the Lexmark Toolbar and then try to print. To install the Firefox version of the Lexmark Toolbar, please visit the link given below:

ME:
I downloaded the Lexmark toolbar and tried to print out this email. Did NOT print out. Only a blank sheet.
What's next.

Cynthia


NOW YOU ARE UP TO DATE WITH MY PROBLEM.

I hope someone here can help me.

the-edmeister

User avatar
 
Posts: 31045
Joined: February 25th, 2003, 12:51 am
Location: Chicago, IL, USA

Post Posted May 20th, 2008, 1:51 am

A mind is a terrible thing to waste. Mine has wandered off and I'm out looking for it.

blueflyer
 
Posts: 3
Joined: May 19th, 2008, 10:12 pm

Post Posted May 21st, 2008, 6:55 pm

[quote="the-edmeister"]http://kb.mozillazine.org/Problems_printing_web_pages

Just went there and tried all suggestions. Won't show on print preview and won't print from websites. It does fine on IE7. What's IE7 have that FF doesn't.

the-edmeister

User avatar
 
Posts: 31045
Joined: February 25th, 2003, 12:51 am
Location: Chicago, IL, USA

Post Posted May 21st, 2008, 8:27 pm

1. After you did the "reset",
http://kb.mozillazine.org/Problems_prin ... et_printer
did you restart Firefox? Did the Lexmark reappear in that preference - print.print_printer?

2. http://kb.mozillazine.org/Problems_prin ... per_at_all
Are you certain that you have the Lexmark selected in Printer > Name: ?

3. regarding:
1. Click on "Start," "Control Panel," "Printers and Other Hardware" and "Printers and Faxes."
2. Then, right click on the Lexmark printer icon and left click "Properties."
3. Either on the "Advanced" tab or the "General" tab for some models,
there is a "Print Processor" button, left click it.
4. This is the spool format setting. Under "Print processor" it should be set to "Lexmark 1300 series print processor." Next, under "Default datatype," select "NT EMF 1.008."
5 . Click "OK" and exit back out to your desktop.
6. Please try printing again.
Have you tried opening the Properties thru the "native print dialog" window that appears in Firefox when you do {Ctrl + P}, and checked to see if printer spooling is turned on when viewed thru Firefox?
Very important that you check that from within Firefox thru the "native print dialog" window > Properties, because AFAIK that setting can vary for the individual program using the print drivers. But then again I have never had a Lexmark printer and their drivers, my direct experience is with Epson, Brother, and HP printers.

Ed
A mind is a terrible thing to waste. Mine has wandered off and I'm out looking for it.

blueflyer
 
Posts: 3
Joined: May 19th, 2008, 10:12 pm

Post Posted May 22nd, 2008, 12:46 am

1. I assume by 'restart' Firefox you mean put it down then bring it back up not shut down the whole computer.
I did do both though. The Lexmark did not reappear on the Firefox restart but did reappear on the computer shut down and restart.

2. Yes

3. Yes

[Have you tried opening the Properties thru the "native print dialog" window that appears in Firefox when you do {Ctrl + P}, and checked to see if printer spooling is turned on when viewed thru Firefox? ]

Do you mean when you open the print box the properties button that is next to the box containing the printer you are using. Yes I did open that properties button, I did it thru {Ctrl + P}

"native print dialog" I don't know what you mean

checked to see if printer spooling is turned on??? when viewed thru Firefox???

'within Firefox' ?? thru the "native print dialog" window > Properties,

What is AFAIK??

I had my son hook up his HP all in one printer on my computer and I installed it. It works fine.

My Lexmark worked up to about 2 or 3 weeks ago off of websites. It still works on Microsoft Word.

Cynthia

Guest
Guest
 

Post Posted November 5th, 2008, 7:54 pm

Your posting was awsome. I had the same issue and this fixed it in minutes.

Thank you,

Richard

Guest
Guest
 

Post Posted May 27th, 2009, 10:33 am

printer hp photosmart c4435 will not print on firefox but switch to the butterfly and it prints ?

hoppinjalapeno
Guest
 

Post Posted July 13th, 2010, 9:52 pm

I was experiencing a similar issue on my hp after updating drivers. When I opened the printers and faxes dialogue, there were two copies of my printer there for some reason. I deleted one, and this solved the problem for me.

Return to Firefox Support


Who is online

Users browsing this forum: Google Adsense [Bot] and 20 guests