MozillaZine

[Theme] Phoenity Next (formerly Phoenity Reborn)

Announce and Discuss the Latest Theme and Extension Releases.
Xavius
 
Posts: 97
Joined: June 1st, 2008, 3:59 am

Post Posted June 1st, 2008, 4:01 am

The wonderful Phoenity theme, renewed for Firefox 3.
A simple and colorful theme for everyone, with a new style.

DOWNLOAD
https://addons.mozilla.org/en-US/firefox/addon/7379

Please vote it on Mozilla.org
and post comments here ;)

thanks
Last edited by Xavius on August 1st, 2009, 9:07 am, edited 3 times in total.

Tuxman
 
Posts: 609
Joined: August 23rd, 2004, 11:53 am

Post Posted June 1st, 2008, 4:36 am

Great, I loved Phoenity in Fx2. :D
Testing immediately.

Xavius
 
Posts: 97
Joined: June 1st, 2008, 3:59 am

Post Posted June 12th, 2008, 2:08 pm

with the latest release 0.8.92
+ the weird bug with Linux should be fixed now
- <b>I need the help of some Firefox theme author, using MAC OS</b>, to fix some graphic bugs that happens using Phoenity Reborn theme with the MAC OS version of Firefox 3.... if someone can/want help me, please write me here or use my mail. <i>thanks in advance</i>

SlimShady
 
Posts: 148
Joined: November 4th, 2004, 3:21 pm

Post Posted June 13th, 2008, 3:19 pm

There's a bug in the theme on Windows XP. When I hover/click the main menu, the text color changes to white and makes it unreadable.
Suggestion: either keep the text color black or change the background color to blue, same as the menu items.

Xavius
 
Posts: 97
Joined: June 1st, 2008, 3:59 am

Post Posted June 15th, 2008, 4:17 am

SlimShady wrote:There's a bug in the theme on Windows XP. When I hover/click the main menu, the text color changes to white and makes it unreadable.
Suggestion: either keep the text color black or change the background color to blue, same as the menu items.


no one has this bug with Win XP, I'm a Win XP user too, and it's all perfect here
are you using a custom (unofficial) windows theme? can you tell me more about this?

Tuxman
 
Posts: 609
Joined: August 23rd, 2004, 11:53 am

Post Posted June 15th, 2008, 4:31 am

I'm using the Classic theme, and I don't have this problem...

SlimShady
 
Posts: 148
Joined: November 4th, 2004, 3:21 pm

Post Posted June 15th, 2008, 2:21 pm

Oh right, I'm using Luna Element 5.1. The same happens with the Royale theme.
So it appears it conflicts with other Windows themes. Will or can you add support for other themes?

Xavius
 
Posts: 97
Joined: June 1st, 2008, 3:59 am

Post Posted June 15th, 2008, 2:24 pm

are you using the latest version of Phoenity Reborn?
I'm using Firefox, with Phoenity Reborn theme and Windows with Royale Theme right now, and it's all ok

SlimShady
 
Posts: 148
Joined: November 4th, 2004, 3:21 pm

Post Posted June 15th, 2008, 2:34 pm

That's strange. I have disabled all addons using safemode and then enabled this theme.
The menu text really turns white and unreadable. Only the default Windows XP theme won't do that.

edit:
I found the cause and fixed it manually. In menu.css line 148 you have:
Code: Select all
color: -moz-menuhovertext;

When you hover over menu items, it changes the text to white, right? That line applies it to the main menu text.
I changed the value to black (inherit works too) and all is fine.

Xavius
 
Posts: 97
Joined: June 1st, 2008, 3:59 am

Post Posted June 16th, 2008, 1:44 pm

I made some changes in menu.css to fix some bug with Linux users
menu text turns white, but highligth should be dark blue......

DoodoM

User avatar
 
Posts: 2
Joined: June 16th, 2008, 11:49 pm

Post Posted June 16th, 2008, 11:56 pm

Xavius wrote:I made some changes in menu.css to fix some bug with Linux users
menu text turns white, but highligth should be dark blue......

Thanks a lot for the change! Anyways, could you make the text to turn white just when the background is highlighted? When the cursor is dragged over the menu texts, they look like hidden.

BTW, very good work. :wink:

gotmikhail
 
Posts: 1
Joined: June 18th, 2008, 5:54 am

Post Posted June 18th, 2008, 6:58 am

Has anyone else had a problem with the nav icons on OS X 10.4? I tried it out on XP and didn't see any problems.
http://gotmikhail.com/temp/phoenity.png

If I go to Customize the toolbars, then click on Restore Default Set, the icons show up correctly, until I click Done and then the problem just reappears. Do you think this is linked to my own configuration?
http://gotmikhail.com/temp/phoenity_good.png

I've been a big fan of Phoenity since it came out
--------
updated a couple hours later...

Also, the scrollbar doesn't display on a page... ? It does display with the default theme. W/ phoenity there's whitespace where the scrollbar (vert or horiz)should be and you can "blindly" click, drag, etc

Xavius
 
Posts: 97
Joined: June 1st, 2008, 3:59 am

Post Posted June 18th, 2008, 1:29 pm

yes, they are two well know bugs with Mac OS, I don't have a mac, so it's not easy for me to do tests and fix them.....
it's hard because the scrollbar issue is impossible to fix without using custom scrollbar, for example, and the back/forward buttons issue needs test with a Mac OS and I don't have it.

If you read the third post, I'm asking for help of some Mac theme creator :idea:

deadman36g

User avatar
 
Posts: 49
Joined: January 5th, 2006, 12:14 pm
Location: Fort Smith, USA

Post Posted June 18th, 2008, 2:45 pm

Really love the theme (didn't think I would find one for FF3 that I like so much, so fast.) I am not really crazy about the throbber though, could you please tell me how to disable it?

Xavius
 
Posts: 97
Joined: June 1st, 2008, 3:59 am

Post Posted June 19th, 2008, 1:35 pm

Deadman36g wrote:Really love the theme (didn't think I would find one for FF3 that I like so much, so fast.) I am not really crazy about the throbber though, could you please tell me how to disable it?


there is no such option built-in in firefox.... the solution is to install an extension that change the throbber
I can make an extension to restore the default throbber if you are interested :wink:

Return to Extension/Theme Releases


Who is online

Users browsing this forum: No registered users and 2 guests