MozillaZine

Thunderbird won't open browser

Discussion of general topics about Mozilla Thunderbird
RobF
 
Posts: 17
Joined: April 27th, 2004, 2:22 pm
Location: Boston, MA, USA

Post Posted April 27th, 2004, 2:24 pm

I'm using Mandrake Linux v.9.2 with KDE v.3.1.4 and Thunderbird v.0.5 and Firefox v.0.8.

Thunderbird doesn't access a web browser when I click on a hyperlink in an email or a news posting. When I do that, I get an error message saying that "galeon-bin" crashed (I've never been able to run Galeon in this Linux installation; I've always gotten that same error message). So I removed Galeon, and now nothing happens when I click on a URL within a message in Thunderbird.

Why would TB attempt to start up the Gnome browser Galeon when my desktop is KDE and my default browser in KDE is Konqueror (i.e. the application associated with MIME type html is Konqueror).

Similarly, any other attempt to have Thunderbird connect to a webpage fails. Examples: clicking on "Release Notes" or "Mozilla Thunderbird Help" in the Help Menu, or clicking on "Download New Themes" or "Get New Extensions" in the Tools> Options menu - nothing happens. Thunderbird will connect to my email and news servers though.

Ideally, I'd like to have TB start up Firefox under these conditions. How do I configure it to do that?

Thanks for your help.

Robert

RobF
 
Posts: 17
Joined: April 27th, 2004, 2:22 pm
Location: Boston, MA, USA

Post Posted April 27th, 2004, 2:25 pm

Other people who are using Thunderbird under Linux also seem to have run into the problem of not having their default browser start up when they click on a URL in Thunderbird.

Searching further, I came across a recent thread addressing this problem in the Mozilla Thunderbird General forum (Title: No response clicking on links, from 2/27/04 1:41 a.m.). See:
http://forums.mozillazine.org/viewtopic ... lt+browser

I've followed the advice offered in that thread about how to change the default browser from within GNOME and that has almost fixed the problem. Specifically, here's what I've done:

Logout from KDE, login again with GNOME as the desktop environment, go to Configuration > GNOME > GNOME Control Center, click on it, go to Desktop Preferences > Advanced > Preferred Applications, Web Browser tab, check Custom Web Browser, in the Command field enter the path to the desired browser, followed by %s (e.g. /home/robert/firefox/firefox %s). I also changed the default Mail Reader tab in the same way, e.g. /usr/local/thunderbird/thunderbird %s. I didn't check the Start in Terminal box in either case.

Now clicking on a URL in Thunderbird does fire up Firefox; however, a problem remains if Firefox is already open. In the above thread, Lokrin reports that he encountered the same problem. He writes:

"Hi - I'm also having problems. I went ahead and set Firefox as the default browser using the Gnome config program mentioned above. The problem now is that if firefox is already open, then clicking a link in Thunderbird causes the dialog for chosing a profile to open. How do I get it to use the same profile but either a different tab or window, or even just overwriting the current tab/window."

Any help?

Robert

Beastux
 
Posts: 4
Joined: April 28th, 2004, 12:50 pm
Location: Senlis, France

Post Posted April 28th, 2004, 1:06 pm

RobF, here's what I did to be able to use Firefox as default browser from Thunderbird with my Gentoo (should work with Mandrake too) :

1- Create a shell script called "openlink.sh" in Thunderbird's directory (/opt/MozillaThunderbird for me) containing the following lines :

#!/bin/sh

export MOZILLA_FIVE_HOME="/opt/firefox"

url="$1"
if [ "x$url" = "x" ]; then
url="about:blank"
fi

if $MOZILLA_FIVE_HOME/mozilla-xremote-client openURL\("$url, new-tab"\); then
exit 0
fi
exec $MOZILLA_FIVE_HOME/firefox "$url"

2- chmod +x /opt/MozillaThunderbird/openlink.sh

3- Create a file called user.js in your ~/.thunderbird/default/xxx/ containing :

// Use firefox for http, https & ftp links
user_pref("network.protocol-handler.app.http", "/opt/MozillaThunderbird/openlink.sh");
user_pref("network.protocol-handler.app.https", "/opt/MozillaThunderbird/openlink.sh");
user_pref("network.protocol-handler.app.ftp", "/opt/MozillaThunderbird/openlink.sh");

4- Copy mozilla-xremote-client from /opt/MozillaThunderbird/ to /opt/firefox/

If it works, clicking on a URL in Thunderbird will launch Firefox and if Firefox is allready running, it will open a new tab.

Hope it helps you. :D

RobF
 
Posts: 17
Joined: April 27th, 2004, 2:22 pm
Location: Boston, MA, USA

Post Posted April 29th, 2004, 10:15 am

Thanks, Beastux. I did what you suggested, and now it's working like a champ. I can't say though that I understood much of what I was doing when I was following your recipe.

Now, if only the reverse could be done, i.e. have Firefox open a compose window in Thunderbird when I click on an email address in a web page. At this point I'm only getting an error message "mailto is not a registered protocol." Any suggestions?

Beastux
 
Posts: 4
Joined: April 28th, 2004, 12:50 pm
Location: Senlis, France

Post Posted May 1st, 2004, 5:55 am

Hi RobF,

I've finally found out how to have Firefox to open a compose window in Thunderbird when clicking on an email address.

1. Launch Firefox and type "about:config" as address

You must have "network.protocol-handler.external.mailto" set to "true"

2. Create a file called "mailto.sh" in Firefox's directory (/opt/firefox for me) containing the following lines shell script found in another mozillazine post) :

#!/bin/sh
#
#script author: asterix
#http://forums.mozillazine.org/viewtopic.php?p=136157#136157

export MOZILLA_FIVE_HOME=/opt/MozillaThunderbird
export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:$MOZILLA_FIVE_HOME

# try xremote first
if [ $(ps aux | grep thunderbird | wc -l) -gt 1 ]; then
$MOZILLA_FIVE_HOME/mozilla-xremote-client "mailto($1?subject=$2)" && exit 0; fi

# if xremote failed, then launch the program
$MOZILLA_FIVE_HOME/thunderbird -P default -compose "mailto:$1?subject=$2"

3. chmod +x /opt/firefox/mailto.sh

4. Download MozEX from http://texturizer.net/firefox/extensions/#mozex

5. In Firefox, Tools > Options > Extensions > mozex > Settings

Check "Intercept mailto: clicks"

In Commands / Mailer, fill field with /opt/firefox/mailto.sh %r

When you restart Firefox, it should work. [-o<

RobF
 
Posts: 17
Joined: April 27th, 2004, 2:22 pm
Location: Boston, MA, USA

Post Posted May 1st, 2004, 1:09 pm

Thanks for another goodie, Beastux! This one works for me almost flawlessly. There is only a very minor cosmetic problem: when I put the cursor on the highlighted email address in Firefox the status bar shows the address with a prefix of "mailto:", e.g. "mailto:billg@msn.com", and the mailto.sh script moves that entire string over into the address field of the compose window of Thunderbird. My mail server rejects an email with such an address. Of course, it's no big deal to delete that prefix "mailto:" but I may forget to do it and find out a day later that the email didn't go out. Does anyone know how to fix this?

Beastux
 
Posts: 4
Joined: April 28th, 2004, 12:50 pm
Location: Senlis, France

Post Posted May 3rd, 2004, 3:50 am

RobF, here is the right script :

#!/bin/sh

url="$1"

export MOZILLA_FIVE_HOME=/opt/MozillaThunderbird

if [ $(pidof thunderbird-bin | wc -w) -gt 0 ]; then
# thunderbird is running
url=`echo "$url" | sed -e's/^mailto://'`
$MOZILLA_FIVE_HOME/thunderbird -remote "mailto($url)"
else
# thunderbird is not running
$MOZILLA_FIVE_HOME/thunderbird -P default -compose $url
fi

The "mailto" problem doesn't seem to exist anymore with it. :D

RobF
 
Posts: 17
Joined: April 27th, 2004, 2:22 pm
Location: Boston, MA, USA

Post Posted May 3rd, 2004, 10:14 am

Thanks, Beastux, for reworking the Firefox mailto.sh script. Opening Firefox from a URL in Thunderbird and opening Thunderbird from an email address in Firefox both work flawlessly now.

Great to have those capabilities now, and thanks again for all your effort!

Robert

sgilvin
 
Posts: 1
Joined: November 5th, 2002, 7:13 am

Post Posted May 4th, 2004, 8:52 am

I used your script for opening URL's in Firefox 0.8 from Thunderbird 0.6.

Worked for me as well. This is a BIG annoyance solved for me.

I'll probably get around to trying the "mailto support" in Firefox as well.

I wish the Firefox & Thunderbird teams would at least include some
"default support" for these features that can be toggled on and off.
I think a lot of non-IE-users are going with this combination and would
use the options.

It is nice to be able to add custom scripts for your own solutions,
however, I think we are "missing the boat" on converting a lot more
users by igonoring just a little push to this browser & email client combo.

Make this option to easy to ignore & use with other non-IE solutions.

Thank you very much for the scripts above!!

shapeshifter
 
Posts: 4
Joined: April 27th, 2004, 6:28 pm
Location: colorado

Post Posted May 4th, 2004, 10:11 pm

beastux, i just wanted to say thanks as well. i have completed the first fix and am working on the second but haven't quite gotten it to work yet. i agree with sgilvin that there should be tighter built in integration between the two apps. i've also realized that i REALLY need to make the time to teach myself at least the basics of shell scripting. any way thanks again for sharing your scripts.

FreeRangeChicken
 
Posts: 1
Joined: May 5th, 2004, 8:41 am

Post Posted May 5th, 2004, 9:06 am

Thanks for the info, Beastux. Very useful.

Just a note for those that may be having difficulties:
I had to add a path to the "pidof" command in your revised "mailto.sh" script to make it work correctly. In my linux distro (mandrake 9.1) "pidof" lives in "/sbin" which is not part of the regular user path. The "pidof" command may live in a differen't place for other distros, or "/sbin" may be part of the regular user path on other distros which is why it seems to work for others, or they are running as root.

mailto.sh
Code: Select all
 
#!/bin/sh

url="$1"

# !!!MAKE SURE THIS PATH IS CORRECT FOR YOUR INSTALLATION!!!
export MOZILLA_FIVE_HOME=/path/to/thunderbird

if [ $(/sbin/pidof thunderbird-bin | wc -w) -gt 0 ]; then
# thunderbird is running
url=`echo "$url" | sed -e's/^mailto://'`
$MOZILLA_FIVE_HOME/thunderbird -remote "mailto($url)"
else
# thunderbird is not running
$MOZILLA_FIVE_HOME/thunderbird -P default -compose $url
fi


Thanks again, Beastux.

scook94
 
Posts: 66
Joined: April 4th, 2004, 1:56 am

Post Posted May 5th, 2004, 2:15 pm

I've been trying to follow these instructions for my Fedora Core setup. My Firefox and Thunderbird are in subdirectiories of my Home folder, so I've been changing things as necessary. I get to the last step and don't understand what I'm supposed to be copying (I'm new to Linux). There doesn't seem to be a file or folder with that name in my Thunderbird folder. Can someone please help?

4- Copy mozilla-xremote-client from /opt/MozillaThunderbird/ to /opt/firefox/


EDIT: Ok, scratch that last request, I just tried it after a reboot and it seems to be working fine! :)

Since these .sh files are in the program's home folders am I right in thinking that they going to need to be replaced should I update to newer versions of Firefox and Thunderbird?

shapeshifter
 
Posts: 4
Joined: April 27th, 2004, 6:28 pm
Location: colorado

Post Posted May 5th, 2004, 7:00 pm

hey, freerangechicken, i was having problems with the firefox fix and i also run drake (9.2) and after specifying the full path to pidof all was well. thank you.

Mike Healan
 
Posts: 107
Joined: November 7th, 2002, 12:32 pm

Post Posted May 16th, 2004, 11:03 am

Ah man, that script to force TB to open FF is beautiful. Works perfectly on Mandrake 10/KDE.

Thanks. I was starting to give up. Nearly every search result for this subject resulted in a forum troll telling people to search.

utanja

User avatar
 
Posts: 51
Joined: September 24th, 2003, 1:28 pm
Location: Europe;Salzburg, Austria USA:Orlando,FL

Post Posted May 17th, 2004, 8:18 pm

thank you so much for posting these scripts.....i prefer to use firebird and thunderbird and not Mozilla Suite.....now i use both with truly no problems for install and execution....again thank you so much...
i am female and i don't do windows and definitely don't do macs..
i fly a LearJet--- tonyaflies.com

Return to Thunderbird General


Who is online

Users browsing this forum: No registered users and 1 guest