MozillaZine

Thunderbird 0.7 Release Candidate Now Available For Testing

Discussion about official Mozilla Thunderbird builds
mscott

User avatar
 
Posts: 2516
Joined: April 2nd, 2003, 4:10 pm
Location: Thunderbird Research Center, CA

Post Posted June 14th, 2004, 7:39 pm

You can download the release candidate here:

http://ftp.mozilla.org/pub/mozilla.org/ ... ses/0.7rc/

<b>What's New</b>
<ol>
<li>Talkback is a part of the the builds for all 3 platforms. Talkback is a tool that generates crash report data which helps us measure the stability of the product and figure out where crashes are happening.
<li>Thunderbird 0.7 bits use the new Extension Manager developed for Firefox. When installing a theme or extension, it must be written to the new EM APIs that Ben Goodger has document for Firefox or it will not install.
<li>Static builds for all platforms. Yielding a smaller disk size and a really nice performance win across the board. OS X bits also use pre-binding now giving yet another big performance boost.
<li>Windows installer uses 7-zip compression for a new download size of only 5.9MB (5.7 without talkback)! Woo Hoo!
<li>Multiple Identity UI for creating multiple identities for a given account.
<li>New inline vCard UI
<li>New profile manager including new profile manager UI.
<li>Signature gets styled in the compose window with the same styles used when you view a signature in the message window.
<li>Color quoting for message qutoes.
<li>OS X fix for Thunderbird locking up when coming out of sleep mode (top 0.6 issue)
<li>OS X: if no Thunderbird windows are open and you click on the system dock icon, we re-open the main mail window. (top 0.6 issue)
<li>LDAP fix for users using LDAP version 2 servers. In 0.6 you could not access these servers without manually changing some preferences. Now if we don't detect version 3, we gracefully fall back and use version 2 (top 0.6 issue).
<li>The download more option in the spell checker dialog now takes you to a web page with various localized dictionaries.
<li>Junk mail fix where sometimes the junk mail filter would mark a message as junk but fail to move it to the Junk folder.
<li>Minor improvements to the junk mail algorithm.
<li>If you do a custom windows install with the windows installer you now see a screen which asks you if you want desktop/start bar/quick launch icons for the installation.
<li>Sorting is now supported in the news subscribe dialog.
<li>Opening a vCard attachment now opens the vCard internally in our addresss book UI instead of launching an external application.
<li>In the offline settings panel, some of the settings were not being saved (like the one for compacting a folder if it saves X KB"
<li>DOM Inspector is no longer part of the windows installer. It is still part of the full .zip build
<li>On Windows, Thunderbird properly handles mailto url clicks (from a browser or another app) that contain raw unencoded spaces.
<li>Continued IMAP improvements and bug fixes including a potential hang when reading imap over SSL.
<li>All of the 1.7 final bug fixes that weren't in 1.7 RC1 (which 0.6 was based on)
</ol>

<b>Known Issues</b>
<ol>
<li>Windows users who are upgrading may need to restart their computer after installing 0.7 if the new mail indicator is not appearing correctly in the Windows system tray.
</ol>
Last edited by mscott on June 16th, 2004, 11:30 am, edited 1 time in total.
Thunderbirds are Go!

jmontana
 
Posts: 558
Joined: March 14th, 2003, 1:36 pm
Location: RI

Post Posted June 14th, 2004, 8:47 pm

Looking good!

The only thing I notice so far is when starting the app, it launches, then seems to quit, then relaunches itself. Very odd. (This with the OS X build.)

Welly Wu
 
Posts: 5
Joined: June 2nd, 2004, 5:16 pm
Location: West Orange, NJ

Post Posted June 14th, 2004, 9:05 pm

I got a slight question / problem. I downloaded ThunderBird 0.7RC and I use Microsoft Windows XP Professional SP-1a. I can't retrieve my e-mail messages. I hit the get all messages button and nothing happens. I didn't change any settings so I am wondering if anyone else can help me out here. FWIW, I re-installed TB 0.7RC twice and rebooted cold twice with no resolution to my issue. I can't retrieve e-mail messages. What to do?

chrisro
 
Posts: 49
Joined: April 6th, 2004, 12:50 pm

Post Posted June 14th, 2004, 9:38 pm

Welly Wu wrote:I got a slight question / problem. I downloaded ThunderBird 0.7RC and I use Microsoft Windows XP Professional SP-1a. I can't retrieve my e-mail messages. I hit the get all messages button and nothing happens.


You might have a message on the mail server that thunderbird does not like. Sometimes happens with corrupt headers i believe. I had this happen recently and had to delete one particular message from the server and then everything was back to normal.

mscott

User avatar
 
Posts: 2516
Joined: April 2nd, 2003, 4:10 pm
Location: Thunderbird Research Center, CA

Post Posted June 14th, 2004, 9:41 pm

You might be stuck in "offline mode". Try downloading theinstaller again this time doing a custom install and choosing to install the offline extension.

When the app starts up look at the offline indicator in the lower right hand corner of the screen and click it to force yourself back on line.
Thunderbirds are Go!

sixshot
 
Posts: 1
Joined: June 14th, 2004, 11:00 pm

Post Posted June 14th, 2004, 11:04 pm

Small question however... do we need to retrain the filter system? I prefer installing some apps via zip file so I wonder if I'll still be able to do either an overwrite or delete+extract to install 0.7.

Waldo

User avatar
 
Posts: 596
Joined: July 29th, 2003, 8:21 am
Location: Cambridge, MA

Post Posted June 14th, 2004, 11:06 pm

What's the bug# for 22? I think I've been experiencing it for the last month with my new email address, and if that bug's been fixed Thunderbird now owns even more!

(My problem involved sending IMAP email with attachments. It would usually hang while copying the message to the Sent folder [but it always actually sent properly according to recipients]. As I haven't been able to really reproduce it I haven't filed a bug. [At one point I filed bugs whenever I encountered them, but now I only file ones that are extremely simple to duplicate.])

Waldo

User avatar
 
Posts: 596
Joined: July 29th, 2003, 8:21 am
Location: Cambridge, MA

Post Posted June 14th, 2004, 11:11 pm

sixshot wrote:Small question however... do we need to retrain the filter system? I prefer installing some apps via zip file so I wonder if I'll still be able to do either an overwrite or delete+extract to install 0.7.

Disk space for email is cheap...I've got a folder called Junk where I've stored all my junk emails since I started TB. I simply start up a new version, mark 'em as junk, and then enter a few of my larger folders (that also happen to be most quickly filled) and mark the stuff in them as not junk. Bam, filter mostly trained.

Speaking of starting from scratch and transferring settings and such, is there a good bug for email/filter/addressbook backup capability to a single file? TB really needs this - heck, even Outlook has backups to PST files (which have been pretty much reverse-engineered and thus somewhat enable compatibility).

Jaska
 
Posts: 113
Joined: January 6th, 2004, 12:54 pm

Post Posted June 15th, 2004, 12:02 am

It is annoying that I just learned to use theQuick-Reply extension and now it is disabled! Thes constant changes make me nervous... Now I am stuck with the 4. June static, where the old manager stall works. ](*,)

Volkm@r
 
Posts: 226
Joined: September 29th, 2003, 12:03 am

Post Posted June 15th, 2004, 12:27 am

Where did they move the setup movemail interface that had been introduced with Thunderbird 0.5?
I can't find it anymore.
Regression, or did they put it somewhere else?

This screenshot was taken from Thunderbird 0.5
<img src="http://home.arcor.de/plsdontreply/movemail.jpg">

boba23

User avatar
 
Posts: 729
Joined: May 6th, 2004, 11:20 am

Post Posted June 15th, 2004, 1:15 am

anyone else having trouble with the systray new mail notification with 0.7RC? just installed it over 0613 branch, everything seems ok, except that i dont get notification in systray for new mail anymore :-( rebooted the machine, but systray still no good ....

any clues?

boba

boba23

User avatar
 
Posts: 729
Joined: May 6th, 2004, 11:20 am

Post Posted June 15th, 2004, 1:18 am

hmm correction :-) it seems to work now, it just didn't when i sent myself a test email .... hehe

regards

boba

petres
 
Posts: 2
Joined: May 7th, 2004, 2:08 am

Post Posted June 15th, 2004, 1:32 am

Waldo wrote:What's the bug# for 22? I think I've been experiencing it for the last month with my new email address, and if that bug's been fixed Thunderbird now owns even more!

(My problem involved sending IMAP email with attachments. It would usually hang while copying the message to the Sent folder [but it always actually sent properly according to recipients]. As I haven't been able to really reproduce it I haven't filed a bug. [At one point I filed bugs whenever I encountered them, but now I only file ones that are extremely simple to duplicate.])


I have sometimes this problem also. In my case, as I have found, it is related to the IMAP server. I use several IMAP servers and just UW IMAP hanged me so far. So there is a bug between Thunderbird and UW IMAP I guess.

rm
 
Posts: 4
Joined: May 1st, 2004, 4:23 pm

Post Posted June 15th, 2004, 1:34 am

i've just upgraded to the 0.7RC and my profile has not be used or loaded (MacOSX), it just asked me to set up a new account... my data is all still there in the profiles dir... how do i get it to use it!!?

pryan

User avatar
 
Posts: 246
Joined: December 8th, 2002, 4:08 am

Post Posted June 15th, 2004, 2:30 am

Just in case it is hard to get 0.7rc from the mirrors:

http://pryan.org/mozilla/thunderbird/of ... ses/0.7rc/

Of course, if my site melts too, then good luck.

Return to Thunderbird Builds


Who is online

Users browsing this forum: No registered users and 1 guest