MozillaZine


SeaMonkey 2.53.14 updated to incompatible (Mac)

Discussion of bugs in Seamonkey
MacTerrassa
 
Posts: 5
Joined: January 23rd, 2023, 10:10 am

Post Posted January 23rd, 2023, 10:23 am

Version 2.53.15 requires at least system 10.12 as indicated by its forbidden icon when installed on a mac running system 10.11 (El Capitan).
In addition to not being indicated anywhere, neither the web, nor the wiki, nor the download page is not indicated in the update window either. What's more, if the serial preferences indicate that it has to update automatically, it does so on its own without the possibility of preventing it. When you exit the program, the program is updated to an incompatible version, rendering it useless.
I understand that by changing the version of Firefox on which it is based, the requirements change (although I don't like it), but not that they do not indicate it anywhere or take it into account when installing updates that prevent reopening the browser. I don't understand. Increasingly, free software works with the same planned and mandatory obsolescence that paid software works with.
Until now, when the requirements changed or when for whatever reason, you didn't want to continue updating, you just canceled and continued working without any problem. But now that is no longer the case: either you update or you update, period. And even better if it is done without any indication that it is happening. Things stop working the day you think, period. To find life.
Regards
MacTerrassa

P.S. Message translated mechanically since I don't speak English, I apologize if I have not expressed myself correctly.
Last edited by DanRaisch on January 23rd, 2023, 3:20 pm, edited 1 time in total.
Reason: (Mac) added to Subject line.

frg
 
Posts: 1278
Joined: December 15th, 2015, 1:20 pm

Post Posted January 23rd, 2023, 4:33 pm

Please try the latest 2.53.16b1 pre https://www.wg9s.com/comm-253/ and see if it fixes the problem. We needed to switch to a later sdk because of backported stuff and problems with later macOS versions. 2.53.15 had a bad default macOS deplyoment target. If the prerelease fixes it I will see that we redo the 2.53.15 macOS version. If not it is unfortunately end of the line for 10.9 to 10.11 macOS versions. In this case I will ask ewong to stop updates and and we will document it on the website.

> Increasingly, free software works with the same planned and mandatory obsolescence that paid software works with.

Tell this to Apple who makes this harder with every sdk and release to support older versions. Windows is actually the system with the best backwards compatibility right now. Linux is a mess too. Wish it would be different.

FRG

James
Moderator

User avatar
 
Posts: 27903
Joined: June 18th, 2003, 3:07 pm
Location: Made in Canada

Post Posted January 23rd, 2023, 5:09 pm

MacTerrassa wrote:Version 2.53.15 requires at least system 10.12 as indicated by its forbidden icon when installed on a mac running system 10.11 (El Capitan).
In addition to not being indicated anywhere, neither the web, nor the wiki, nor the download page is not indicated in the update window either. What's more, if the serial preferences indicate that it has to update automatically, it does so on its own without the possibility of preventing it. When you exit the program, the program is updated to an incompatible version, rendering it useless..

Not sure about SeaMonkey however the last version of Firefox to still support the old EOL Mac OSX 10.9, 10.10, 10.11 was Firefox 78.15.0esr as Firefox 79.0 to current has required Mac OSX 10.12 (ten.twelve) at minimum to run.

Firefox Mac OS X 10.9, 10.10 and 10.11 users move to Extended Support Release (referring to the then current 78.0 ESR)
https://support.mozilla.org/en-US/kb/firefox-mac-osx-users-esr

http://archive.mozilla.org/pub/firefox/releases/78.15.0esr/mac/

If SeaMonkey 2.53.16b1 pre is based on same Gecko as Firefox 91 ESR then it will likely not work on the old EOL MAc OSX 10.11

frg
 
Posts: 1278
Joined: December 15th, 2015, 1:20 pm

Post Posted January 24th, 2023, 4:57 am

Originally based on 56.0.2. Now with about 18400 patches applied not based on any version any longer :)

To support macOS 13 and also a later libangle we needed to go to a later macOS sdk. Breakage was an oversight. I hope with setting a deployment target it will work again. If not as I wrote 10.12 minimum it is but needs to be documented and updates for older versions stopped.

FRG

MacTerrassa
 
Posts: 5
Joined: January 23rd, 2023, 10:10 am

Post Posted January 24th, 2023, 10:10 am

frg wrote:Please try the latest 2.53.16b1 pre https://www.wg9s.com/comm-253/ and see if it fixes the problem. We needed to switch to a later sdk because of backported stuff and problems with later macOS versions. 2.53.15 had a bad default macOS deplyoment target. If the prerelease fixes it I will see that we redo the 2.53.15 macOS version. If not it is unfortunately end of the line for 10.9 to 10.11 macOS versions. In this case I will ask ewong to stop updates and and we will document it on the website.

> Increasingly, free software works with the same planned and mandatory obsolescence that paid software works with.

Tell this to Apple who makes this harder with every sdk and release to support older versions. Windows is actually the system with the best backwards compatibility right now. Linux is a mess too. Wish it would be different.

FRG


The application has a normal icon, without prohibited, but it still does not open. Double-clicking jumps into the dock but closes in two seconds. Without any message. In Console the following lines appear:
24/1/23 18:00:08,080 launchservicesd[92]: SecTaskLoadEntitlements failed error=22
24/1/23 18:00:08,167 launchservicesd[92]: SecTaskLoadEntitlements failed error=22
24/1/23 18:00:08,407 seamonkey[1102]: Minimum OS version requirement not met!
24/1/23 18:00:08,996 com.apple.xpc.launchd[1]: (org.mozilla.seamonkey.2343072[1102]) Service exited with abnormal code: 1

As I was thinking if it was not the system quarantine, I have tried with the xattr command from the terminal, but nothing appeared. I have also tried an "Unquarantaine" application that has helped me on other occasions, and it tells me that it did not have any quarantine to touch.

I have opened the package and read its info.plist file, which indicates 10.9 as a requirement... Where and how does it indicate to the system that it requires a higher one, as the console seems to indicate?
I understand then that it will be some internal library used that requires that later system, but on other occasions I get an alert with the console content and some lines where it appears that there is a problem with a certain library, which is not always where the real problem lies. but in this case it is not so. It closes directly without any message.

I understand that Apple's news is incompatible with the above. This has almost always been so. I don't understand why programs keep trying to update at all costs, without first checking if the update works or not in your case. That was my main problem with SeaMonkey. If the update is not possible, do not do it, period. At most it informs that it exists and that if you want to access it you have to update the system beforehand, as Chrome does. Although it would be better if once the message is canceled it does not come out again. If one does not update, there is a reason for it, or the machine does not accept this new system or you need some software that cannot work on it. There is always some valid reason for it. And those mandatory updates prevent you from continuing to use the computer. And more if they spread throughout the software. So far this year, I have already deleted at least fifty applications that update themselves without meaning, such as Dropbox, WebCatalog and others. Without giving you the slightest chance to go back to the previous version.

MacTerrassa
 
Posts: 5
Joined: January 23rd, 2023, 10:10 am

Post Posted January 24th, 2023, 10:17 am

James wrote:
MacTerrassa wrote:Version 2.53.15 requires at least system 10.12 as indicated by its forbidden icon when installed on a mac running system 10.11 (El Capitan).
In addition to not being indicated anywhere, neither the web, nor the wiki, nor the download page is not indicated in the update window either. What's more, if the serial preferences indicate that it has to update automatically, it does so on its own without the possibility of preventing it. When you exit the program, the program is updated to an incompatible version, rendering it useless..

Not sure about SeaMonkey however the last version of Firefox to still support the old EOL Mac OSX 10.9, 10.10, 10.11 was Firefox 78.15.0esr as Firefox 79.0 to current has required Mac OSX 10.12 (ten.twelve) at minimum to run.

Firefox Mac OS X 10.9, 10.10 and 10.11 users move to Extended Support Release (referring to the then current 78.0 ESR)
https://support.mozilla.org/en-US/kb/firefox-mac-osx-users-esr

http://archive.mozilla.org/pub/firefox/releases/78.15.0esr/mac/

If SeaMonkey 2.53.16b1 pre is based on same Gecko as Firefox 91 ESR then it will likely not work on the old EOL MAc OSX 10.11


I still use that version of Firefox precisely, and I've spent a year trying other options that continued to support my system, or so their website indicated. But this has been changing of course. And now I can't find anything. Or anything similar to TenFourFox for my G5 (which also closes) but for my macs with El Capitan.

But at least Firefox 78.15 continues to work, it is not updated, perhaps many websites prepared for the new versions do not work either... but the program continues to work and is not updated to any incompatible version. That at least allows us to continue for a while. Until the rest of the web forces you to change.

MacTerrassa
 
Posts: 5
Joined: January 23rd, 2023, 10:10 am

Post Posted January 24th, 2023, 10:24 am

frg wrote:Originally based on 56.0.2. Now with about 18400 patches applied not based on any version any longer :)

To support macOS 13 and also a later libangle we needed to go to a later macOS sdk. Breakage was an oversight. I hope with setting a deployment target it will work again. If not as I wrote 10.12 minimum it is but needs to be documented and updates for older versions stopped.

FRG


I understand that it is not easy to maintain the support of the previous systems. And that this is Apple's responsibility. But I also understand that when changes occur developers have to (or should :-) ) test the different supported configurations to see if they really work or not. Or at least when they are notified, communicate that change to the rest and act accordingly: if, as you say, it is possible to solve it and continue offering support, better, if not communicated on the web, on the download page in the help everywhere To avoid complaints from us users we try to use it without really being possible.

Some time ago in all the web pages these requirements were indicated correctly, and in the aids it was put: such a function requires system 10.6, this other 10.8,... and the program opens from 10.4 for example. For some time now, and following Apple's orders, everything indicates: none requirements. apple computer. Point. Because they assume that everyone renews the machine every week if necessary and we are all up to date as we should (for Apple, of course).

frg
 
Posts: 1278
Joined: December 15th, 2015, 1:20 pm

Post Posted January 24th, 2023, 1:25 pm

Check the 01/24 build from today: https://www.wg9s.com/comm-253/

Was done with 10.12 sdk like the official 2.53.15 build but with 10.9 as deployment target. If this does not work I need to give up.

MacTerrassa
 
Posts: 5
Joined: January 23rd, 2023, 10:10 am

Post Posted January 25th, 2023, 4:19 am

frg wrote:Check the 01/24 build from today: https://www.wg9s.com/comm-253/

Was done with 10.12 sdk like the official 2.53.15 build but with 10.9 as deployment target. If this does not work I need to give up.


Hello, trying the new version gives the same result. It does not open, no alert window and the following lines in the console:

25/1/23 12:09:10,614 launchservicesd[92]: SecTaskLoadEntitlements failed error=22
25/1/23 12:09:10,664 launchservicesd[92]: SecTaskLoadEntitlements failed error=22
25/1/23 12:09:10,841 seamonkey[1035]: Minimum OS version requirement not met!
25/1/23 12:09:10,982 com.apple.xpc.launchd[1]: (org.mozilla.seamonkey.2343072[1035]) Service exited with abnormal code: 1

Where are these requirements marked so that the system does not even start the program? In other programs they were started and then closed with a message related to a library with problems (although not always the one ultimately responsible for the failure). And in this case it simply tells me that the requirements are not met.

Thank you very much for trying to fix the problem and continue to support my system, but I see that it may not be possible. Regards.

frg
 
Posts: 1278
Joined: December 15th, 2015, 1:20 pm

Post Posted February 1st, 2023, 2:39 pm

A few more test builds to check: viewtopic.php?p=14948956#p14948956

Return to SeaMonkey Bugs


Who is online

Users browsing this forum: No registered users and 1 guest